# CVE-2025-32021: Weblate VCS credentials included in URL parameters are potentially logged and saved into browser history as plaintext

> Weblate exposes repository credentials in URL parameters, leading to plaintext disclosure in browser history and server logs.

- **Severity:** Low 2.2 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2025
- **Updated:** 16 Apr 2025
- **Also known as:** GHSA-m67m-3p5g-cw9j, PYSEC-2025-35, openSUSE-SU-2025:15055-1

## What is CVE-2025-32021?

CVE-2025-32021 is a low-severity vulnerability in WeblateOrg weblate, published on 15 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Weblate is a web based localization tool. Prior to version 5.11, when creating a new component from an existing component that has a source code repository URL specified in settings, this URL is included in the client's URL parameters during the creation process. If, for example, the source code repository URL contains GitHub credentials, the confidential PAT and username are shown in plaintext and get saved into browser history. Moreover, if the request URL is logged, the credentials are written to logs in plaintext. If using Weblate official Docker image, nginx logs the URL and the token in plaintext. This issue is patched in version 5.11.

Weakness: CWE-598 (Use of HTTP Request With Sensitive Query String)

## Which versions are affected by CVE-2025-32021?

3 open source packages ship an affected version, including weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | All versions | 5.11 |
| `weblate` | PyPI | All versions | 5.11 |
| `weblate` | PyPI | All versions | 5.11 |
| `weblate` | openSUSE:Tumbleweed | All versions | 5.11.3-1.1 |

Products: Weblate Weblate.

## How do I fix CVE-2025-32021?

Upgrade weblate to 5.11 or later.

## Is CVE-2025-32021 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32021 exists.

## Other vulnerabilities in WeblateOrg weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2025-68279](https://insights.sbomify.com/CVE-2025-68279/): Weblate has an arbitrary file read via symbolic links (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32021 and fix it if it is affected.

What it is: CVE-2025-32021 is a low-severity vulnerability in WeblateOrg weblate, published on 15 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32021 exists.

Affected packages and fixed versions:
- weblate (PyPI): affected all versions; fixed in 5.11
- weblate (PyPI): affected all versions; fixed in 5.11
- weblate (PyPI): affected all versions; fixed in 5.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32021/ (Markdown: https://insights.sbomify.com/CVE-2025-32021/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32021
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32021
- OSV: https://osv.dev/vulnerability/CVE-2025-32021

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32021/
Summaries are generated and may contain mistakes; the official description above is the record.
