CVE-2025-32022 Finit has heap based buffer overwrite in urandom.so plugin

Medium 4.6 Published Updated

A heap buffer overwrite in Finit's urandom plugin can cause system instability or arbitrary code execution at boot time.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-32022?

CVE-2025-32022 is a medium-severity memory corruption vulnerability in troglobit finit, published on 6 May 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Finit provides fast init for Linux systems. Finit's urandom plugin has a heap buffer overwrite vulnerability at boot which leads to it overwriting other parts of the heap, possibly causing random instabilities and undefined behavior. The urandom plugin is enabled by default, so this bug affects everyone using Finit 4.2 or later that do not explicitly disable the plugin at build time. This bug is fixed in Finit 4.12. Those who cannot upgrade or backport the fix to urandom.c are strongly recommended to disable the plugin in the call to the `configure` script.

Weakness: CWE-787

Which versions are affected by CVE-2025-32022?

How do I fix CVE-2025-32022?

Upgrade to a fixed version.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-32022 being exploited?

There is no known exploitation of CVE-2025-32022 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2025-32022, GHSA-fv6v-vw8h-9x79, UBUNTU-CVE-2025-32022.

Is CVE-2025-32022 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free