# CVE-2025-32022: Finit has heap based buffer overwrite in urandom.so plugin

> A heap buffer overwrite in Finit's urandom plugin can cause system instability or arbitrary code execution at boot time.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 May 2025
- **Updated:** 6 May 2025
- **Also known as:** DEBIAN-CVE-2025-32022, GHSA-fv6v-vw8h-9x79, UBUNTU-CVE-2025-32022

## What is CVE-2025-32022?

CVE-2025-32022 is a medium-severity memory corruption vulnerability in troglobit finit, published on 6 May 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Finit provides fast init for Linux systems. Finit's urandom plugin has a heap buffer overwrite vulnerability at boot which leads to it overwriting other parts of the heap, possibly causing random instabilities and undefined behavior. The urandom plugin is enabled by default, so this bug affects everyone using Finit 4.2 or later that do not explicitly disable the plugin at build time. This bug is fixed in Finit 4.12. Those who cannot upgrade or backport the fix to urandom.c are strongly recommended to disable the plugin in the call to the `configure` script.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2025-32022?


## How do I fix CVE-2025-32022?

Upgrade to a fixed version.

## Is CVE-2025-32022 being exploited?

There is no known exploitation of CVE-2025-32022 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32022 and fix it if it is affected.

What it is: CVE-2025-32022 is a medium-severity memory corruption vulnerability in troglobit finit, published on 6 May 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-32022 in the wild and no public exploit code.

Affected product: troglobit finit. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32022/ (Markdown: https://insights.sbomify.com/CVE-2025-32022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32022
- OSV: https://osv.dev/vulnerability/CVE-2025-32022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32022/
Summaries are generated and may contain mistakes; the official description above is the record.
