# CVE-2025-32023: Redis allows out of bounds writes in hyperloglog commands leading to RCE

> An authenticated attacker can trigger out-of-bounds writes in Redis hyperloglog operations, potentially leading to remote code execution.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2025
- **Updated:** 4 Feb 2026
- **Also known as:** ALPINE-CVE-2025-32023, AZL-64806, AZL-64824, BELL-CVE-2025-32023, BIT-keydb-2025-32023, BIT-redis-2025-32023, BIT-valkey-2025-32023, CLSA-2025-1754339372, DEBIAN-CVE-2025-32023, ECHO-fcd4-8b43-5a77, GHSA-rp2m-q4j6-gr43, MINI-9c3v-xqmj-6rgp, MINI-jv38-jf64-ccgv, MINI-pvjc-vwhx-6vxw, MINI-r3wv-m4w8-7689, UBUNTU-CVE-2025-32023, USN-8120-1

## What is CVE-2025-32023?

CVE-2025-32023 is a high-severity memory corruption vulnerability in redis, published on 7 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Redis is an open source, in-memory database that persists on disk. From 2.8 to before 8.0.3, 7.4.5, 7.2.10, and 6.2.19, an authenticated user may use a specially crafted string to trigger a stack/heap out of bounds write on hyperloglog operations, potentially leading to remote code execution. The bug likely affects all Redis versions with hyperloglog operations implemented. This vulnerability is fixed in 8.0.3, 7.4.5, 7.2.10, and 6.2.19. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing hyperloglog operations. This can be done using ACL to restrict HLL commands.

Weakness: CWE-680 (Integer Overflow to Buffer Overflow)

## Which versions are affected by CVE-2025-32023?

3 open source packages ship an affected version, including redis, keydb and valkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redis` | Bitnami | From 2.8.0 | 6.2.19, 7.2.10, 8.0.3, 7.4.5 |
| `keydb` | Bitnami | From 2.8.0 | 6.2.19, 7.2.10, 8.0.3, 7.4.5 |
| `valkey` | Bitnami | All versions | 7.2.10, 8.0.4, 8.1.3 |

Products: Redis Redis.

## How do I fix CVE-2025-32023?

Upgrade redis to a fixed version for your release line: 6.2.19, 7.2.10, 8.0.3 or 7.4.5.

## Is CVE-2025-32023 being exploited?

There is no known exploitation of CVE-2025-32023 in the wild and no public exploit code.

Public exploit code:

- PoC & Exploit for CVE-2025-32023 / PlaidCTF 2025 "Zerodeo" (github_poc): https://github.com/leesh3288/CVE-2025-32023
- CVE-2025-32023 (github_poc): https://github.com/44528zja/Blackash-CVE-2025-32023
- Redis 8.0.2 - RCE (exploitdb)

## Other vulnerabilities in redis

- [CVE-2022-0543](https://insights.sbomify.com/CVE-2022-0543/): Debian-specific Redis Server Lua Sandbox Escape (critical 10.0, exploited in the wild)
- [CVE-2026-23479](https://insights.sbomify.com/CVE-2026-23479/): redis-server use-after-free in unblock client flow may allow remote code execution (high 7.7)
- [CVE-2026-25243](https://insights.sbomify.com/CVE-2026-25243/): redis-server RESTORE invalid memory access may allow remote code execution (high 7.7)
- [CVE-2025-62507](https://insights.sbomify.com/CVE-2025-62507/): Redis: Bug in XACKDEL may lead to stack overflow and potential RCE (high 7.7)
- [CVE-2025-48367](https://insights.sbomify.com/CVE-2025-48367/): Redis DoS Vulnerability due to bad connection error handling (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32023 and fix it if it is affected.

What it is: CVE-2025-32023 is a high-severity memory corruption vulnerability in redis, published on 7 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32023 in the wild and no public exploit code.

Affected packages and fixed versions:
- redis (Bitnami): affected from 2.8.0; fixed in 6.2.19, 7.2.10, 8.0.3, 7.4.5
- keydb (Bitnami): affected from 2.8.0; fixed in 6.2.19, 7.2.10, 8.0.3, 7.4.5
- valkey (Bitnami): affected all versions; fixed in 7.2.10, 8.0.4, 8.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32023/ (Markdown: https://insights.sbomify.com/CVE-2025-32023/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32023
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32023
- OSV: https://osv.dev/vulnerability/CVE-2025-32023

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32023/
Summaries are generated and may contain mistakes; the official description above is the record.
