{"answers":{"affected":"2 open source packages ship an affected version, including yiisoft/yii. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-32027 in the wild and no public exploit code.","fix":"Upgrade yiisoft/yii to 1.1.31 or later.","what":"CVE-2025-32027 is a medium-severity cross-site scripting vulnerability in yiisoft yii, published on 10 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-32027 and fix it if it is affected.\n\nWhat it is: CVE-2025-32027 is a medium-severity cross-site scripting vulnerability in yiisoft yii, published on 10 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-32027 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yiisoft/yii (Packagist): affected all versions; fixed in 1.1.31\n- yiisoft/yii (Packagist): affected all versions; fixed in 1.1.31\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32027/ (Markdown: https://insights.sbomify.com/CVE-2025-32027/index.md)","id":"CVE-2025-32027","markdown":"https://insights.sbomify.com/CVE-2025-32027/index.md","name":"CVE-2025-32027","record":{"aliases":["GHSA-7r2v-8wxr-3ch5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via reflected XSS when the fallback error renderer is active in the Yii PHP framework.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yii","vendor":"yiiframework"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Yii does not prevent XSS in scenarios where fallback error renderer is used","id":"CVE-2025-32027","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"HAX CMS PHP allows Insecure File Upload to Lead to Remote Code Execution","id":"CVE-2025-32028"},"packages":[{"ecosystem":"Packagist","fixed":["1.1.31"],"introduced":["0"],"last_affected":[],"package":"yiisoft/yii","purl":null,"source":"GHSA-7r2v-8wxr-3ch5"},{"ecosystem":"Packagist","fixed":["1.1.31"],"introduced":["0"],"last_affected":[],"package":"yiisoft/yii","purl":"pkg:composer/yiisoft/yii","source":"GHSA-7r2v-8wxr-3ch5"}],"prev":{"headline":"Element Web could load a malicious instance of Element Call leaking media encryption keys","id":"CVE-2025-32026"},"products":["yii"],"published":"2025-04-10","related":[{"cvss_score":9,"headline":"Yiiframework Yii Improper Protection of Alternate Path","id":"CVE-2024-58136","kev_date_added":"2025-05-02","published":"2025-04-10"},{"cvss_score":9.8,"headline":"Yii2 allows attackers to execute any local .php file via a relative path in the view parameter","id":"CVE-2015-5467","kev_date_added":null,"published":"2023-09-21"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2023-26750","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":9.8,"headline":"Yii SQL injection vulnerability","id":"CVE-2018-7269","kev_date_added":null,"published":"2018-03-21"},{"cvss_score":9.8,"headline":"yii2-redis Potential Remote code execution","id":"CVE-2018-8073","kev_date_added":null,"published":"2018-03-21"},{"cvss_score":8.9,"headline":"Unsafe deserialization in Yii 2","id":"CVE-2020-15148","kev_date_added":null,"published":"2020-09-15"},{"cvss_score":8.1,"headline":"Unsafe Reflection in base Component class in yiisoft/yii2","id":"CVE-2024-4990","kev_date_added":null,"published":"2025-03-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-10","vendors":["yiisoft"]},"summary":"Attackers can execute arbitrary scripts via reflected XSS when the fallback error renderer is active in the Yii PHP framework.","url":"https://insights.sbomify.com/CVE-2025-32027/"}