# CVE-2025-32027: Yii does not prevent XSS in scenarios where fallback error renderer is used

> Attackers can execute arbitrary scripts via reflected XSS when the fallback error renderer is active in the Yii PHP framework.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Apr 2025
- **Updated:** 10 Apr 2025
- **Also known as:** GHSA-7r2v-8wxr-3ch5

## What is CVE-2025-32027?

CVE-2025-32027 is a medium-severity cross-site scripting vulnerability in yiisoft yii, published on 10 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Yii is an open source PHP web framework. Prior to 1.1.31, yiisoft/yii is vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used. Upgrade yiisoft/yii to version 1.1.31 or higher.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-32027?

2 open source packages ship an affected version, including yiisoft/yii. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii` | Packagist | All versions | 1.1.31 |
| `yiisoft/yii` | Packagist | All versions | 1.1.31 |

Products: Yiiframework Yii.

## How do I fix CVE-2025-32027?

Upgrade yiisoft/yii to 1.1.31 or later.

## Is CVE-2025-32027 being exploited?

There is no known exploitation of CVE-2025-32027 in the wild and no public exploit code.

## Other vulnerabilities in yiisoft yii

- [CVE-2024-58136](https://insights.sbomify.com/CVE-2024-58136/): Yiiframework Yii Improper Protection of Alternate Path (critical 9.0, exploited in the wild)
- [CVE-2015-5467](https://insights.sbomify.com/CVE-2015-5467/): Yii2 allows attackers to execute any local .php file via a relative path in the view parameter (critical 9.8)
- [CVE-2023-26750](https://insights.sbomify.com/CVE-2023-26750/): SQL injection in n/a (critical 9.8)
- [CVE-2018-7269](https://insights.sbomify.com/CVE-2018-7269/): Yii SQL injection vulnerability (critical 9.8)
- [CVE-2018-8073](https://insights.sbomify.com/CVE-2018-8073/): yii2-redis Potential Remote code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32027 and fix it if it is affected.

What it is: CVE-2025-32027 is a medium-severity cross-site scripting vulnerability in yiisoft yii, published on 10 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-32027 in the wild and no public exploit code.

Affected packages and fixed versions:
- yiisoft/yii (Packagist): affected all versions; fixed in 1.1.31
- yiisoft/yii (Packagist): affected all versions; fixed in 1.1.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32027/ (Markdown: https://insights.sbomify.com/CVE-2025-32027/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32027
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32027
- OSV: https://osv.dev/vulnerability/CVE-2025-32027

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32027/
Summaries are generated and may contain mistakes; the official description above is the record.
