{"answers":{"affected":"2 open source packages ship an affected version, including @apeleghq/asn1-der.","exploited":"There is no known exploitation of CVE-2025-32029 in the wild and no public exploit code.","fix":"Upgrade @apeleghq/asn1-der to 1.0.4 or later.","what":"CVE-2025-32029 is a medium-severity denial of service vulnerability in ApelegHQ ts-asn1-der, published on 7 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32029 and fix it if it is affected.\n\nWhat it is: CVE-2025-32029 is a medium-severity denial of service vulnerability in ApelegHQ ts-asn1-der, published on 7 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-32029 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @apeleghq/asn1-der (npm): affected all versions; fixed in 1.0.4\n- @apeleghq/asn1-der (npm): affected all versions; fixed in 1.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32029/ (Markdown: https://insights.sbomify.com/CVE-2025-32029/index.md)","id":"CVE-2025-32029","markdown":"https://insights.sbomify.com/CVE-2025-32029/index.md","name":"CVE-2025-32029","record":{"aliases":["GHSA-p4qw-7j9g-5h53"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"ASN.1 DER encoding library","requires_auth":"none","summary":"Incorrect DER encoding of specific large integers causes an infinite loop, leading to denial of service in applications using the ts-asn1-der library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"},{"id":"CWE-1335","name":"Incorrect Bitwise Shift of Integer"}],"description":"ts-asn1-der is a collection of utility classes to encode ASN.1 data following DER rule. Incorrect number DER encoding can lead to denial on service for absolute values in the range 2**31 -- 2**32 - 1. The arithmetic in the numBitLen didn't take into account that values in this range could result in a negative result upon applying the \u003e\u003e operator, leading to an infinite loop. The issue is patched in version 1.0.4. If upgrading is not an option, the issue can be mitigated by validating inputs to Asn1Integer to ensure that they are not smaller than -2**31 + 1 and no larger than 2**31 - 1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ts-asn1-der has Incorrect DER Encoding of Numbers Leading to Denial of Service and Incorrect Value Representation","id":"CVE-2025-32029","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Named Fragment Expansion","id":"CVE-2025-32030"},"packages":[{"ecosystem":"npm","fixed":["1.0.4"],"introduced":["0"],"last_affected":[],"package":"@apeleghq/asn1-der","purl":null,"source":"GHSA-p4qw-7j9g-5h53"},{"ecosystem":"npm","fixed":["1.0.4"],"introduced":["0"],"last_affected":[],"package":"@apeleghq/asn1-der","purl":"pkg:npm/%40apeleghq/asn1-der","source":"GHSA-p4qw-7j9g-5h53"}],"prev":{"headline":"HAX CMS PHP allows Insecure File Upload to Lead to Remote Code Execution","id":"CVE-2025-32028"},"products":["ts-asn1-der"],"published":"2025-04-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-08","vendors":["ApelegHQ"]},"summary":"Incorrect DER encoding of specific large integers causes an infinite loop, leading to denial of service in applications using the ts-asn1-der library.","url":"https://insights.sbomify.com/CVE-2025-32029/"}