# CVE-2025-32029: ts-asn1-der has Incorrect DER Encoding of Numbers Leading to Denial of Service and Incorrect Value Representation

> Incorrect DER encoding of specific large integers causes an infinite loop, leading to denial of service in applications using the ts-asn1-der library.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2025
- **Updated:** 8 Apr 2025
- **Also known as:** GHSA-p4qw-7j9g-5h53

## What is CVE-2025-32029?

CVE-2025-32029 is a medium-severity denial of service vulnerability in ApelegHQ ts-asn1-der, published on 7 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

ts-asn1-der is a collection of utility classes to encode ASN.1 data following DER rule. Incorrect number DER encoding can lead to denial on service for absolute values in the range 2**31 -- 2**32 - 1. The arithmetic in the numBitLen didn't take into account that values in this range could result in a negative result upon applying the >> operator, leading to an infinite loop. The issue is patched in version 1.0.4. If upgrading is not an option, the issue can be mitigated by validating inputs to Asn1Integer to ensure that they are not smaller than -2**31 + 1 and no larger than 2**31 - 1.

Weakness: CWE-835 (Loop with Unreachable Exit Condition), CWE-1335 (Incorrect Bitwise Shift of Integer)

## Which versions are affected by CVE-2025-32029?

2 open source packages ship an affected version, including @apeleghq/asn1-der.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apeleghq/asn1-der` | npm | All versions | 1.0.4 |
| `@apeleghq/asn1-der` | npm | All versions | 1.0.4 |

## How do I fix CVE-2025-32029?

Upgrade @apeleghq/asn1-der to 1.0.4 or later.

## Is CVE-2025-32029 being exploited?

There is no known exploitation of CVE-2025-32029 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32029 and fix it if it is affected.

What it is: CVE-2025-32029 is a medium-severity denial of service vulnerability in ApelegHQ ts-asn1-der, published on 7 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32029 in the wild and no public exploit code.

Affected packages and fixed versions:
- @apeleghq/asn1-der (npm): affected all versions; fixed in 1.0.4
- @apeleghq/asn1-der (npm): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32029/ (Markdown: https://insights.sbomify.com/CVE-2025-32029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32029
- OSV: https://osv.dev/vulnerability/CVE-2025-32029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32029/
Summaries are generated and may contain mistakes; the official description above is the record.
