{"answers":{"affected":"2 open source packages ship an affected version, including @apollo/gateway. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-32030 in the wild and no public exploit code.","fix":"Upgrade @apollo/gateway to 2.10.1 or later.","what":"CVE-2025-32030 is a high-severity denial of service vulnerability in apollographql federation, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32030 and fix it if it is affected.\n\nWhat it is: CVE-2025-32030 is a high-severity denial of service vulnerability in apollographql federation, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-32030 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @apollo/gateway (npm): affected all versions; fixed in 2.10.1\n- @apollo/gateway (npm): affected all versions; fixed in 2.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32030/ (Markdown: https://insights.sbomify.com/CVE-2025-32030/index.md)","id":"CVE-2025-32030","markdown":"https://insights.sbomify.com/CVE-2025-32030/index.md","name":"CVE-2025-32030","record":{"aliases":["GHSA-q2f9-x4p4-7xmh","ROOT-APP-NPM-CVE-2025-32030"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apollo Gateway library","requires_auth":"none","summary":"Attackers can cause denial of service in Apollo Gateway by sending queries with deeply nested named fragments, leading to excessive resource consumption during planning.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apollo_gateway","vendor":"apollographql"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Apollo Gateway provides utilities for combining multiple GraphQL microservices into a single GraphQL endpoint. Prior to 2.10.1, a vulnerability in Apollo Gateway allowed queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically during named fragment expansion. Named fragments were being expanded once per fragment spread during query planning, leading to exponential resource usage when deeply nested and reused fragments were involved. This could lead to excessive resource consumption and denial of service. This has been remediated in @apollo/gateway version 2.10.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Named Fragment Expansion","id":"CVE-2025-32030","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Optimization Bypass","id":"CVE-2025-32031"},"packages":[{"ecosystem":"npm","fixed":["2.10.1"],"introduced":["0"],"last_affected":[],"package":"@apollo/gateway","purl":null,"source":"GHSA-q2f9-x4p4-7xmh"},{"ecosystem":"npm","fixed":["2.10.1"],"introduced":["0"],"last_affected":[],"package":"@apollo/gateway","purl":"pkg:npm/%40apollo/gateway","source":"GHSA-q2f9-x4p4-7xmh"}],"prev":{"headline":"ts-asn1-der has Incorrect DER Encoding of Numbers Leading to Denial of Service and Incorrect Value Representation","id":"CVE-2025-32029"},"products":["federation"],"published":"2025-04-07","related":[{"cvss_score":7.5,"headline":"Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Optimization Bypass","id":"CVE-2025-32031","kev_date_added":null,"published":"2025-04-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-08","vendors":["apollographql"]},"summary":"Attackers can cause denial of service in Apollo Gateway by sending queries with deeply nested named fragments, leading to excessive resource consumption during planning.","url":"https://insights.sbomify.com/CVE-2025-32030/"}