# CVE-2025-32030: Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Named Fragment Expansion

> Attackers can cause denial of service in Apollo Gateway by sending queries with deeply nested named fragments, leading to excessive resource consumption during planning.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2025
- **Updated:** 8 Apr 2025
- **Also known as:** GHSA-q2f9-x4p4-7xmh, ROOT-APP-NPM-CVE-2025-32030

## What is CVE-2025-32030?

CVE-2025-32030 is a high-severity denial of service vulnerability in apollographql federation, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apollo Gateway provides utilities for combining multiple GraphQL microservices into a single GraphQL endpoint. Prior to 2.10.1, a vulnerability in Apollo Gateway allowed queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically during named fragment expansion. Named fragments were being expanded once per fragment spread during query planning, leading to exponential resource usage when deeply nested and reused fragments were involved. This could lead to excessive resource consumption and denial of service. This has been remediated in @apollo/gateway version 2.10.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-32030?

2 open source packages ship an affected version, including @apollo/gateway. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@apollo/gateway` | npm | All versions | 2.10.1 |
| `@apollo/gateway` | npm | All versions | 2.10.1 |

Products: Apollographql Apollo Gateway.

## How do I fix CVE-2025-32030?

Upgrade @apollo/gateway to 2.10.1 or later.

## Is CVE-2025-32030 being exploited?

There is no known exploitation of CVE-2025-32030 in the wild and no public exploit code.

## Other vulnerabilities in apollographql federation

- [CVE-2025-32031](https://insights.sbomify.com/CVE-2025-32031/): Apollo Gateway Query Planner Vulnerable to Excessive Resource Consumption via Optimization Bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32030 and fix it if it is affected.

What it is: CVE-2025-32030 is a high-severity denial of service vulnerability in apollographql federation, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32030 in the wild and no public exploit code.

Affected packages and fixed versions:
- @apollo/gateway (npm): affected all versions; fixed in 2.10.1
- @apollo/gateway (npm): affected all versions; fixed in 2.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32030/ (Markdown: https://insights.sbomify.com/CVE-2025-32030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32030
- OSV: https://osv.dev/vulnerability/CVE-2025-32030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32030/
Summaries are generated and may contain mistakes; the official description above is the record.
