CVE-2025-32033 Apollo Router Operation Limits Vulnerable to Bypass via Integer Overflow
An integer overflow in Apollo Router allows attackers to bypass operation limits, potentially enabling resource exhaustion or policy evasion.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-32033?
CVE-2025-32033 is a high-severity vulnerability in apollographql router, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Apollo Router Core is a configurable, high-performance graph router written in Rust to run a federated supergraph that uses Apollo Federation 2. Prior to 1.61.2 and 2.1.1, the operation limits plugin uses unsigned 32-bit integers to track limit counters (e.g. for a query's height). If a counter exceeded the maximum value for this data type (4,294,967,295), it wrapped around to 0, unintentionally allowing queries to bypass configured thresholds. This could occur for large queries if the payload limit were sufficiently increased, but could also occur for small queries with deeply nested and reused named fragments. This has been remediated in apollo-router versions 1.61.2 and 2.1.1.
Weakness: CWE-119
Which versions are affected by CVE-2025-32033?
4 open source packages ship an affected version, including apollo-router.
| Package | Affected | Fixed in |
|---|---|---|
apollo-router crates.io | All versions | 1.61.2 |
apollo-router crates.io | All versions | 1.61.2 |
apollo-router crates.io | From 2.0.0-alpha.0 | 2.1.1 |
apollo-router crates.io | From 2.0.0-alpha.0 | 2.1.1 |
How do I fix CVE-2025-32033?
Upgrade apollo-router to a fixed version for your release line: 1.61.2 or 2.1.1.
Is CVE-2025-32033 being exploited?
There is no known exploitation of CVE-2025-32033 in the wild and no public exploit code.
Sources
Also known as GHSA-84m6-5m72-45fp.