CVE-2025-32034 Apollo Router Query Planner Vulnerable to Excessive Resource Consumption via Named Fragment Expansion
Attackers can cause denial of service in Apollo Router by sending queries with deeply nested named fragments, leading to excessive resource consumption during planning.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-32034?
CVE-2025-32034 is a high-severity denial of service vulnerability in apollographql router, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Apollo Router Core is a configurable, high-performance graph router written in Rust to run a federated supergraph that uses Apollo Federation 2. Prior to 1.61.2 and 2.1.1, a vulnerability in Apollo Router allowed queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically during named fragment expansion. Named fragments were being expanded once per fragment spread during query planning, leading to exponential resource usage when deeply nested and reused fragments were involved. This could lead to excessive resource consumption and denial of service. This has been remediated in apollo-router versions 1.61.2 and 2.1.1.
Weakness: CWE-770
Which versions are affected by CVE-2025-32034?
4 open source packages ship an affected version, including apollo-router.
| Package | Affected | Fixed in |
|---|---|---|
apollo-router crates.io | All versions | 1.61.2 |
apollo-router crates.io | All versions | 1.61.2 |
apollo-router crates.io | From 2.0.0-alpha.0 | 2.1.1 |
apollo-router crates.io | From 2.0.0-alpha.0 | 2.1.1 |
How do I fix CVE-2025-32034?
Upgrade apollo-router to a fixed version for your release line: 1.61.2 or 2.1.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-32034 being exploited?
There is no known exploitation of CVE-2025-32034 in the wild and no public exploit code.
Sources
Also known as GHSA-75m2-jhh5-j5g2.