{"answers":{"affected":"4 open source packages ship an affected version, including apollo-router.","exploited":"There is no known exploitation of CVE-2025-32034 in the wild and no public exploit code.","fix":"Upgrade apollo-router to a fixed version for your release line: 1.61.2 or 2.1.1.","what":"CVE-2025-32034 is a high-severity denial of service vulnerability in apollographql router, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32034 and fix it if it is affected.\n\nWhat it is: CVE-2025-32034 is a high-severity denial of service vulnerability in apollographql router, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-32034 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apollo-router (crates.io): affected all versions; fixed in 1.61.2\n- apollo-router (crates.io): affected all versions; fixed in 1.61.2\n- apollo-router (crates.io): affected from 2.0.0-alpha.0; fixed in 2.1.1\n- apollo-router (crates.io): affected from 2.0.0-alpha.0; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32034/ (Markdown: https://insights.sbomify.com/CVE-2025-32034/index.md)","id":"CVE-2025-32034","markdown":"https://insights.sbomify.com/CVE-2025-32034/index.md","name":"CVE-2025-32034","record":{"aliases":["GHSA-75m2-jhh5-j5g2"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apollo Router","requires_auth":"none","summary":"Attackers can cause denial of service in Apollo Router by sending queries with deeply nested named fragments, leading to excessive resource consumption during planning.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"The Apollo Router Core is a configurable, high-performance graph router written in Rust to run a federated supergraph that uses Apollo Federation 2. Prior to 1.61.2 and 2.1.1, a vulnerability in Apollo Router allowed queries with deeply nested and reused named fragments to be prohibitively expensive to query plan, specifically during named fragment expansion. Named fragments were being expanded once per fragment spread during query planning, leading to exponential resource usage when deeply nested and reused fragments were involved. This could lead to excessive resource consumption and denial of service. This has been remediated in apollo-router versions 1.61.2 and 2.1.1.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apollo Router Query Planner Vulnerable to Excessive Resource Consumption via Named Fragment Expansion","id":"CVE-2025-32034","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"DNN does not check the contents of a file when uploading files","id":"CVE-2025-32035"},"packages":[{"ecosystem":"crates.io","fixed":["1.61.2"],"introduced":["0"],"last_affected":[],"package":"apollo-router","purl":null,"source":"GHSA-75m2-jhh5-j5g2"},{"ecosystem":"crates.io","fixed":["1.61.2"],"introduced":["0"],"last_affected":[],"package":"apollo-router","purl":"pkg:cargo/apollo-router","source":"GHSA-75m2-jhh5-j5g2"},{"ecosystem":"crates.io","fixed":["2.1.1"],"introduced":["2.0.0-alpha.0"],"last_affected":[],"package":"apollo-router","purl":null,"source":"GHSA-75m2-jhh5-j5g2"},{"ecosystem":"crates.io","fixed":["2.1.1"],"introduced":["2.0.0-alpha.0"],"last_affected":[],"package":"apollo-router","purl":"pkg:cargo/apollo-router","source":"GHSA-75m2-jhh5-j5g2"}],"prev":{"headline":"Apollo Router Operation Limits Vulnerable to Bypass via Integer Overflow","id":"CVE-2025-32033"},"products":["router"],"published":"2025-04-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-08","vendors":["apollographql"]},"summary":"Attackers can cause denial of service in Apollo Router by sending queries with deeply nested named fragments, leading to excessive resource consumption during planning.","url":"https://insights.sbomify.com/CVE-2025-32034/"}