{"answers":{"affected":"3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-32044 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to 4.5.3 or later.","what":"CVE-2025-32044 is a high-severity vulnerability in Moodle Moodle, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32044 and fix it if it is affected.\n\nWhat it is: CVE-2025-32044 is a high-severity vulnerability in Moodle Moodle, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-32044 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.3\n- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.3\n- moodle (Bitnami): affected from 4.5.0; fixed in 4.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32044/ (Markdown: https://insights.sbomify.com/CVE-2025-32044/index.md)","id":"CVE-2025-32044","markdown":"https://insights.sbomify.com/CVE-2025-32044/index.md","name":"CVE-2025-32044","record":{"aliases":["BIT-moodle-2025-32044","GHSA-345q-9jmq-g9q4","UBUNTU-CVE-2025-32044"],"analysis":{"component_type":"web_application","fix_type":"configuration_change","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Moodle LMS","requires_auth":"none","summary":"Unauthenticated attackers can retrieve sensitive user data via API stack traces on Moodle sites with specific PHP configurations.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A flaw has been identified in Moodle where, on certain sites, unauthenticated users could retrieve sensitive user data—including names, contact information, and hashed passwords—via stack traces returned by specific API calls. Sites with PHP configured with zend.exception_ignore_args = 1 in the php.ini file are not affected by this vulnerability.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":"2026-07-15","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-07-15T18:54:08Z","kind":"github_poc","ref":"https://github.com/shinthink/CVE-2025-32044","stars":0,"title":"Moodle 4.5.0-4.5.2 Unauthenticated REST API User Data Exposure via Stack Trace Args Leak | CVSS 7.5"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Moodle: unauthenticated rest api user data exposure","id":"CVE-2025-32044","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"information_disclosure","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Moodle: hidden grades shown to users without permission on some grade reports","id":"CVE-2025-32045"},"packages":[{"ecosystem":"Bitnami","fixed":["4.5.3"],"introduced":["4.5.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2025-32044"},{"ecosystem":"Packagist","fixed":["4.5.3"],"introduced":["4.5.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-345q-9jmq-g9q4"},{"ecosystem":"Packagist","fixed":["4.5.3"],"introduced":["4.5.0-beta"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-345q-9jmq-g9q4"}],"prev":{"headline":"Privilege escalation in Intel oneAPI DPC++C++ Compiler software","id":"CVE-2025-32038"},"products":["moodle:moodle"],"published":"2025-04-25","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-25","vendors":["moodle"]},"summary":"Unauthenticated attackers can retrieve sensitive user data via API stack traces on Moodle sites with specific PHP configurations.","url":"https://insights.sbomify.com/CVE-2025-32044/"}