# CVE-2025-32044: Moodle: unauthenticated rest api user data exposure

> Unauthenticated attackers can retrieve sensitive user data via API stack traces on Moodle sites with specific PHP configurations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2025
- **Updated:** 25 Apr 2025
- **Also known as:** BIT-moodle-2025-32044, GHSA-345q-9jmq-g9q4, UBUNTU-CVE-2025-32044

## What is CVE-2025-32044?

CVE-2025-32044 is a high-severity vulnerability in Moodle Moodle, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw has been identified in Moodle where, on certain sites, unauthenticated users could retrieve sensitive user data—including names, contact information, and hashed passwords—via stack traces returned by specific API calls. Sites with PHP configured with zend.exception_ignore_args = 1 in the php.ini file are not affected by this vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-32044?

3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.3 |
| `moodle/moodle` | Packagist | From 4.5.0-beta | 4.5.3 |
| `moodle` | Bitnami | From 4.5.0 | 4.5.3 |

Products: Moodle Moodle.

## How do I fix CVE-2025-32044?

Upgrade moodle/moodle to 4.5.3 or later.

## Is CVE-2025-32044 being exploited?

There is no known exploitation of CVE-2025-32044 in the wild and no public exploit code.

Public exploit code:

- Moodle 4.5.0-4.5.2 Unauthenticated REST API User Data Exposure via Stack Trace Args Leak | CVSS 7.5 (github_poc): https://github.com/shinthink/CVE-2025-32044

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32044 and fix it if it is affected.

What it is: CVE-2025-32044 is a high-severity vulnerability in Moodle Moodle, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32044 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.3
- moodle/moodle (Packagist): affected from 4.5.0-beta; fixed in 4.5.3
- moodle (Bitnami): affected from 4.5.0; fixed in 4.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32044/ (Markdown: https://insights.sbomify.com/CVE-2025-32044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32044
- OSV: https://osv.dev/vulnerability/CVE-2025-32044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32044/
Summaries are generated and may contain mistakes; the official description above is the record.
