CVE-2025-32045 Moodle: hidden grades shown to users without permission on some grade reports
Attackers can view hidden grades in Moodle reports without proper permissions due to insufficient capability checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-32045?
CVE-2025-32045 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A flaw has been identified in Moodle where insufficient capability checks in certain grade reports allowed users without the necessary permissions to access hidden grades.
Weakness: CWE-862
Which versions are affected by CVE-2025-32045?
9 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 4.1.17 |
moodle/moodle Packagist | All versions | 4.1.17 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.11 |
moodle/moodle Packagist | From 4.3.0-beta | 4.3.11 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.7 |
moodle/moodle Packagist | From 4.4.0-beta | 4.4.7 |
3 more packages
moodle/moodle Packagist | From 4.5.0-beta | 4.5.3 |
moodle/moodle Packagist | From 4.5.0-beta | 4.5.3 |
moodle Bitnami | All versions | 4.1.17, 4.3.11, 4.4.7, 4.5.3 |
Products include Moodle Moodle.
How do I fix CVE-2025-32045?
Upgrade moodle/moodle to a fixed version for your release line: 4.1.17, 4.3.11, 4.4.7 or 4.5.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-32045 being exploited?
There is no known exploitation of CVE-2025-32045 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2025-32045, GHSA-8m7c-hm88-2p97, UBUNTU-CVE-2025-32045.