CVE-2025-32093 Syatem admin profile modification by delegated granular administration role
Delegated administrators can improperly modify system admin profiles due to missing authorization checks, enabling privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-32093?
CVE-2025-32093 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 14 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to restrict certain operations on system admins to only other system admins, which allows delegated granular administration users with the "Edit Other Users" permission to perform unauthorized modifications to system administrators via improper permission validation.
Weakness: CWE-863
Which versions are affected by CVE-2025-32093?
18 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250227102013-aa4623a93199 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250227102013-aa4623a93199 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250227102013-aa4623a93199 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0 | 10.4.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0 | 10.4.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.2 |
12 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.10 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.10 |
github.com/mattermost/mattermost-server Go | From 10.4.0 | 10.4.4 |
github.com/mattermost/mattermost-server Go | From 10.4.0 | 10.4.4 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.2 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.2 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.10 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.10 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.10+incompatible, 10.4.4+incompatible, 10.5.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-32093?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250227102013-aa4623a93199, 10.4.4, 10.5.2 or 9.11.10.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-32093 being exploited?
There is no known exploitation of CVE-2025-32093 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-322v-vh2g-qvpv, GO-2025-3609.