CVE-2025-3225 XML Entity Expansion vulnerability in run-llama/llama_index
Attackers can cause denial of service via memory exhaustion using malicious XML sitemaps in the llama_index library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-3225?
CVE-2025-3225 is a high-severity denial of service vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An XML Entity Expansion vulnerability, also known as a 'billion laughs' attack, exists in the sitemap parser of the run-llama/llama_index repository, specifically affecting version v0.12.21. This vulnerability allows an attacker to supply a malicious Sitemap XML, leading to a Denial of Service (DoS) by exhausting system memory and potentially causing a system crash. The issue is resolved in version v0.12.29.
Weakness: CWE-776
Which versions are affected by CVE-2025-3225?
4 open source packages ship an affected version, including llama-index-readers-papers and llama-index. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
llama-index-readers-papers PyPI | All versions | 0.3.2 |
llama-index-readers-papers PyPI | All versions | 0.3.2 |
llama-index-readers-papers PyPI | All versions | 0.3.2 |
llama-index PyPI | From 0.12.21 | 0.12.29 |
Products include Llamaindex Llamaindex.
How do I fix CVE-2025-3225?
Upgrade llama-index-readers-papers to 0.3.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-3225 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3225 exists.
Other vulnerabilities in run-llama/llama_index
Sources
Also known as GHSA-w42r-mrx7-c633, PYSEC-2025-250, PYSEC-2026-1570.