CVE-2025-3228 Unauthorized Guest user access to Playbook

Medium 4.3 Published Updated

Attackers can access playbook runs as unauthorized guest users due to improper requestor information retrieval in Mattermost.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-3228?

CVE-2025-3228 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 20 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 10.5.x <= 10.5.5, 9.11.x <= 9.11.15, 10.8.x <= 10.8.0, 10.7.x <= 10.7.2, 10.6.x <= 10.6.5 fail to properly retrieve requestorInfo from playbooks handler for guest users which allows an attacker access to the playbook run.

Weakness: CWE-863

Which versions are affected by CVE-2025-3228?

18 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250520060012-d0380305ef7a
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250520060012-d0380305ef7a
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250520060012-d0380305ef7a
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.6
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.6
github.com/mattermost/mattermost/server/v8 GoFrom 10.6.010.6.6
12 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 10.6.010.6.6
github.com/mattermost/mattermost/server/v8 GoFrom 10.7.010.7.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.7.010.7.3
github.com/mattermost/mattermost/server/v8 GoFrom 10.8.010.8.1
github.com/mattermost/mattermost/server/v8 GoFrom 10.8.010.8.1
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.16
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.16
github.com/mattermost/mattermost-server GoAll versions0.0.0-20250520060012-d0380305ef7a, 9.11.16+incompatible, 10.5.6+incompatible, 10.6.6+incompatible, 10.7.3+incompatible, 10.8.1+incompatible
github.com/mattermost/mattermost-server GoAll versions0.0.0-20250520060012-d0380305ef7a
github.com/mattermost/mattermost-server GoAll versions0.0.0-20250520060012-d0380305ef7a
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-3228?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250520060012-d0380305ef7a, 10.5.6, 10.6.6 or 10.7.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-3228 being exploited?

There is no known exploitation of CVE-2025-3228 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-4578-6gjh-f2jm, GO-2025-3771.

Is CVE-2025-3228 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free