CVE-2025-3230 Bypass of System Admin User Deactivation Controls for Personal Access Tokens in Mattermost Server
Deactivated users retain full system access via valid personal access tokens, allowing unauthorized privilege escalation in Mattermost Server.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-3230?
CVE-2025-3230 is a medium-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 30 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.7.x <= 10.7.0, 10.6.x <= 10.6.2, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fails to properly invalidate personal access tokens upon user deactivation, allowing deactivated users to maintain full system access by exploiting access token validation flaws via continued usage of previously issued tokens.
Weakness: CWE-303
Which versions are affected by CVE-2025-3230?
14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250402193107-65343f84a783 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250402193107-65343f84a783 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250402193107-65343f84a783 |
github.com/mattermost/mattermost/server/v8 Go | From 10.0.0-rc1 | 10.5.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.0.0-rc1 | 10.5.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.6.0-rc1 | 10.6.3 |
8 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.6.0-rc1 | 10.6.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.7.0-rc1 | 10.7.1 |
github.com/mattermost/mattermost/server/v8 Go | From 10.7.0-rc1 | 10.7.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.0.0-rc1 | 9.11.13 |
github.com/mattermost/mattermost/server/v8 Go | From 9.0.0-rc1 | 9.11.13 |
github.com/mattermost/mattermost-server Go | From 9.0.0-rc1+incompatible | 9.11.13+incompatible, 10.5.4+incompatible, 10.6.3+incompatible, 10.7.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-3230?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250402193107-65343f84a783, 10.5.4, 10.6.3 or 10.7.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-3230 being exploited?
There is no known exploitation of CVE-2025-3230 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-mc2f-jgj6-6cp3, GO-2025-3731.