CVE-2025-32376 Discourse DM limits aren’t always properly enforced

Medium 4.8 Published Updated

Attackers can bypass direct message user limits to create DMs with all site users, potentially exposing private user data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-32376?

CVE-2025-32376 is a medium-severity vulnerability in Discourse Discourse, published on 30 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Discourse is an open-source discussion platform. Prior to versions 3.4.3 on the stable branch and 3.5.0.beta3 on the beta branch, the users limit for a DM can be bypassed, thus giving the ability to potentially create a DM with every user from a site in it. This issue has been patched in stable version 3.4.3 and beta version 3.5.0.beta3.

Weakness: CWE-284

Which versions are affected by CVE-2025-32376?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.4.3

Products include Discourse Discourse.

How do I fix CVE-2025-32376?

Upgrade discourse to 3.4.3 or later.

Is CVE-2025-32376 being exploited?

There is no known exploitation of CVE-2025-32376 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2025-32376, GHSA-mqqq-h2x3-46fr.

Is CVE-2025-32376 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free