CVE-2025-32378 Shopware's default newsletter opt-in settings allow for mass sign-up abuse
Attackers can mass-sign up arbitrary email addresses for newsletters due to flawed default double-opt-in logic, spamming recipients and polluting subscriber lists.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-32378?
CVE-2025-32378 is a medium-severity vulnerability in Shopware Shopware, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Shopware is an open source e-commerce software platform. Prior to 6.6.10.3 or 6.5.8.17, the default settings for double-opt-in allow for mass unsolicited newsletter sign-ups without confirmation. Default settings are Newsletter: Double Opt-in set to active, Newsletter: Double opt-in for registered customers set to disabled, and Log-in & sign-up: Double opt-in on sign-up set to disabled. With these settings, anyone can register an account on the shop using any e-mail-address and then check the check-box in the account page to sign up for the newsletter. The recipient will receive two mails confirming registering and signing up for the newsletter, no confirmation link needed to be clicked for either. In the backend the recipient is set to “instantly active”. This vulnerability is fixed in 6.6.10.3 or 6.5.8.17.
Weakness: CWE-799
Which versions are affected by CVE-2025-32378?
12 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
shopware/core Packagist | All versions | 6.5.8.17 |
shopware/core Packagist | All versions | 6.5.8.17 |
shopware/core Packagist | From 6.6.0.0-rc1 | 6.6.10.3 |
shopware/core Packagist | From 6.6.0.0-rc1 | 6.6.10.3 |
shopware/core Packagist | From 6.7.0.0-rc1 | 6.7.0.0-rc2 |
shopware/core Packagist | From 6.7.0.0-rc1 | 6.7.0.0-rc2 |
6 more packages
shopware/platform Packagist | All versions | 6.5.8.17 |
shopware/platform Packagist | All versions | 6.5.8.17 |
shopware/platform Packagist | From 6.6.0.0-rc1 | 6.6.10.3 |
shopware/platform Packagist | From 6.6.0.0-rc1 | 6.6.10.3 |
shopware/platform Packagist | From 6.7.0.0-rc1 | 6.7.0.0-rc2 |
shopware/platform Packagist | From 6.7.0.0-rc1 | 6.7.0.0-rc2 |
Products include Shopware Shopware.
How do I fix CVE-2025-32378?
Upgrade shopware/core to a fixed version for your release line: 6.5.8.17, 6.6.10.3 or 6.7.0.0-rc2.
Is CVE-2025-32378 being exploited?
There is no known exploitation of CVE-2025-32378 in the wild and no public exploit code.
Other vulnerabilities in Shopware Shopware
- CVE-2023-22731 Improper Control of Generation of Code in Twig rendered views in shopware
- CVE-2016-3109 Shopware RCE Vulnerability
- CVE-2024-22406 Blind SQL-injection in DAL aggregations in Shopware
- CVE-2021-32711 Leak of information via Store-API
- CVE-2026-31887 Shopware unauthenticated data extraction possible through store-api.order endpoint
Sources
Also known as GHSA-4h9w-7vfp-px8m.