# CVE-2025-32386: Helm Allows A Specially Crafted Chart Archive To Cause Out Of Memory Termination

> Attackers can cause Helm to crash via memory exhaustion by providing a specially crafted chart archive with high compression ratios.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2025
- **Updated:** 10 Apr 2025
- **Also known as:** AZL-59808, AZL-59838, AZL-59991, AZL-60145, BIT-helm-2025-32386, CLEANSTART-2026-EE09812, CLEANSTART-2026-WA53854, CLEANSTART-2026-WI36826, ECHO-6a95-874b-c333, GHSA-4hfp-h4cw-hj8p, GO-2025-3601, MINI-2mff-8h2j-66cg, MINI-3853-5m45-fc27, MINI-4r93-hvxc-m458, MINI-f4g8-9m36-h596, MINI-gjx2-53mv-jp8g, MINI-hm5f-8g3g-m9h4, MINI-jh3w-g4fj-7x2g, MINI-x8gw-vphh-w4qm, MINI-xhjw-5xxf-pcf7, UBUNTU-CVE-2025-32386

## What is CVE-2025-32386?

CVE-2025-32386 is a medium-severity denial of service vulnerability in helm, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Helm is a tool for managing Charts. A chart archive file can be crafted in a manner where it expands to be significantly larger uncompressed than compressed (e.g., >800x difference). When Helm loads this specially crafted chart, memory can be exhausted causing the application to terminate. This issue has been resolved in Helm v3.17.3.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value), CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-32386?

4 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm/v3` | Go | All versions | 3.17.3 |
| `helm.sh/helm/v3` | Go | All versions | 3.17.3 |
| `helm.sh/helm/v3` | Go | All versions | 3.17.3 |
| `helm` | Bitnami | All versions | 3.17.3 |

Products: Helm Helm.

## How do I fix CVE-2025-32386?

Upgrade helm.sh/helm/v3 to 3.17.3 or later.

## Is CVE-2025-32386 being exploited?

There is no known exploitation of CVE-2025-32386 in the wild and no public exploit code.

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32386 and fix it if it is affected.

What it is: CVE-2025-32386 is a medium-severity denial of service vulnerability in helm, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-32386 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.17.3
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.17.3
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.17.3
- helm (Bitnami): affected all versions; fixed in 3.17.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32386/ (Markdown: https://insights.sbomify.com/CVE-2025-32386/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32386
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32386
- OSV: https://osv.dev/vulnerability/CVE-2025-32386

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32386/
Summaries are generated and may contain mistakes; the official description above is the record.
