{"answers":{"affected":"4 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-32387 in the wild and no public exploit code.","fix":"Upgrade helm.sh/helm/v3 to 3.17.3 or later.","what":"CVE-2025-32387 is a medium-severity denial of service vulnerability in helm, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-32387 and fix it if it is affected.\n\nWhat it is: CVE-2025-32387 is a medium-severity denial of service vulnerability in helm, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-32387 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.17.3\n- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.17.3\n- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.17.3\n- helm (Bitnami): affected all versions; fixed in 3.17.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32387/ (Markdown: https://insights.sbomify.com/CVE-2025-32387/index.md)","id":"CVE-2025-32387","markdown":"https://insights.sbomify.com/CVE-2025-32387/index.md","name":"CVE-2025-32387","record":{"aliases":["AZL-59979","AZL-60172","BIT-helm-2025-32387","CLEANSTART-2026-GF48427","CLEANSTART-2026-PV63985","CLEANSTART-2026-WC68837","ECHO-602e-7f74-affe","GHSA-5xqw-8hwv-wg92","GO-2025-3602","MINI-33j2-v96v-m632","MINI-5prw-63rm-cv3h","MINI-62r6-r37h-h72r","MINI-96gv-r9hj-mhvp","MINI-99q7-xf7m-ch7j","MINI-f5rg-hgp5-xmg5","MINI-fc44-qc2p-c8qp","MINI-jjvc-wp46-7hc6","MINI-qq39-fcw2-qmw2","UBUNTU-CVE-2025-32387"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes package manager","requires_auth":"none","summary":"Attackers can cause a stack overflow and denial of service in Helm by providing a chart with a deeply nested JSON schema.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"helm","vendor":"helm"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"},{"id":"CWE-121","name":"Stack-based Buffer Overflow"}],"description":"Helm is a package manager for Charts for Kubernetes. A JSON Schema file within a chart can be crafted with a deeply nested chain of references, leading to parser recursion that can exceed the stack size limit and trigger a stack overflow. This issue has been resolved in Helm v3.17.3.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Helm Allows A Specially Crafted JSON Schema To Cause A Stack Overflow","id":"CVE-2025-32387","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"SvelteKit allows XSS via tracked search_params","id":"CVE-2025-32388"},"packages":[{"ecosystem":"Bitnami","fixed":["3.17.3"],"introduced":["0"],"last_affected":[],"package":"helm","purl":"pkg:bitnami/helm","source":"BIT-helm-2025-32387"},{"ecosystem":"Go","fixed":["3.17.3"],"introduced":["0"],"last_affected":[],"package":"helm.sh/helm/v3","purl":null,"source":"GHSA-5xqw-8hwv-wg92"},{"ecosystem":"Go","fixed":["3.17.3"],"introduced":["0"],"last_affected":[],"package":"helm.sh/helm/v3","purl":"pkg:golang/helm.sh/helm/v3","source":"GHSA-5xqw-8hwv-wg92"},{"ecosystem":"Go","fixed":["3.17.3"],"introduced":["0"],"last_affected":[],"package":"helm.sh/helm/v3","purl":"pkg:golang/helm.sh/helm/v3","source":"GO-2025-3602"}],"prev":{"headline":"Helm Allows A Specially Crafted Chart Archive To Cause Out Of Memory Termination","id":"CVE-2025-32386"},"products":["helm"],"published":"2025-04-09","related":[{"cvss_score":9.8,"headline":"Helm Unsafe Link Following","id":"CVE-2019-18658","kev_date_added":null,"published":"2019-11-12"},{"cvss_score":9.8,"headline":"Helm Improper Certificate Validation","id":"CVE-2019-1010275","kev_date_added":null,"published":"2019-07-17"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2019-25210","kev_date_added":null,"published":"2024-03-03"},{"cvss_score":8.5,"headline":"Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution","id":"CVE-2025-53547","kev_date_added":null,"published":"2025-07-08"},{"cvss_score":8.5,"headline":"lookup Function Information Discolosure in Helm","id":"CVE-2020-11013","kev_date_added":null,"published":"2020-04-24"},{"cvss_score":8.4,"headline":"Helm has a path traversal in plugin metadata version enables arbitrary file write outside Helm plugin directory","id":"CVE-2026-35204","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":8.4,"headline":"Helm's plugin verification fails open when .prov is missing, allowing unsigned plugin install","id":"CVE-2026-35205","kev_date_added":null,"published":"2026-04-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-10","vendors":["helm"]},"summary":"Attackers can cause a stack overflow and denial of service in Helm by providing a chart with a deeply nested JSON schema.","url":"https://insights.sbomify.com/CVE-2025-32387/"}