# CVE-2025-32387: Helm Allows A Specially Crafted JSON Schema To Cause A Stack Overflow

> Attackers can cause a stack overflow and denial of service in Helm by providing a chart with a deeply nested JSON schema.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2025
- **Updated:** 10 Apr 2025
- **Also known as:** AZL-59979, AZL-60172, BIT-helm-2025-32387, CLEANSTART-2026-GF48427, CLEANSTART-2026-PV63985, CLEANSTART-2026-WC68837, ECHO-602e-7f74-affe, GHSA-5xqw-8hwv-wg92, GO-2025-3602, MINI-33j2-v96v-m632, MINI-5prw-63rm-cv3h, MINI-62r6-r37h-h72r, MINI-96gv-r9hj-mhvp, MINI-99q7-xf7m-ch7j, MINI-f5rg-hgp5-xmg5, MINI-fc44-qc2p-c8qp, MINI-jjvc-wp46-7hc6, MINI-qq39-fcw2-qmw2, UBUNTU-CVE-2025-32387

## What is CVE-2025-32387?

CVE-2025-32387 is a medium-severity denial of service vulnerability in helm, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Helm is a package manager for Charts for Kubernetes. A JSON Schema file within a chart can be crafted with a deeply nested chain of references, leading to parser recursion that can exceed the stack size limit and trigger a stack overflow. This issue has been resolved in Helm v3.17.3.

Weakness: CWE-674 (Uncontrolled Recursion), CWE-121 (Stack-based Buffer Overflow)

## Which versions are affected by CVE-2025-32387?

4 open source packages ship an affected version, including helm.sh/helm/v3 and helm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm/v3` | Go | All versions | 3.17.3 |
| `helm.sh/helm/v3` | Go | All versions | 3.17.3 |
| `helm.sh/helm/v3` | Go | All versions | 3.17.3 |
| `helm` | Bitnami | All versions | 3.17.3 |

Products: Helm Helm.

## How do I fix CVE-2025-32387?

Upgrade helm.sh/helm/v3 to 3.17.3 or later.

## Is CVE-2025-32387 being exploited?

There is no known exploitation of CVE-2025-32387 in the wild and no public exploit code.

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32387 and fix it if it is affected.

What it is: CVE-2025-32387 is a medium-severity denial of service vulnerability in helm, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-32387 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.17.3
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.17.3
- helm.sh/helm/v3 (Go): affected all versions; fixed in 3.17.3
- helm (Bitnami): affected all versions; fixed in 3.17.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32387/ (Markdown: https://insights.sbomify.com/CVE-2025-32387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32387
- OSV: https://osv.dev/vulnerability/CVE-2025-32387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32387/
Summaries are generated and may contain mistakes; the official description above is the record.
