# CVE-2025-32388: SvelteKit allows XSS via tracked search_params

> Attackers can execute arbitrary scripts in user browsers by crafting malicious URLs with unsanitized search parameters in SvelteKit server load functions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Apr 2025
- **Updated:** 16 Apr 2025
- **Also known as:** GHSA-6q87-84jw-cjhp

## What is CVE-2025-32388?

CVE-2025-32388 is a medium-severity cross-site scripting vulnerability in sveltejs kit, published on 15 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Prior to 2.20.6 , unsanitized search param names cause XSS vulnerability. You are affected if you iterate over all entries of event.url.searchParams inside a server load function. Attackers can exploit it by crafting a malicious URL and getting a user to click a link with said URL. This vulnerability is fixed in 2.20.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-32388?

2 open source packages ship an affected version, including @sveltejs/kit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sveltejs/kit` | npm | From 2.0.0 | 2.20.6 |
| `@sveltejs/kit` | npm | From 2.0.0 | 2.20.6 |

## How do I fix CVE-2025-32388?

Upgrade @sveltejs/kit to 2.20.6 or later.

## Is CVE-2025-32388 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32388 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32388 and fix it if it is affected.

What it is: CVE-2025-32388 is a medium-severity cross-site scripting vulnerability in sveltejs kit, published on 15 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32388 exists.

Affected packages and fixed versions:
- @sveltejs/kit (npm): affected from 2.0.0; fixed in 2.20.6
- @sveltejs/kit (npm): affected from 2.0.0; fixed in 2.20.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32388/ (Markdown: https://insights.sbomify.com/CVE-2025-32388/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32388
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32388
- OSV: https://osv.dev/vulnerability/CVE-2025-32388

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32388/
Summaries are generated and may contain mistakes; the official description above is the record.
