# CVE-2025-32394: AutoGPT: There is a DoS vulnerability in AITextSummarizerBlock

> Attackers can cause denial of service in AutoGPT by amplifying input to exhaust server memory resources.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** GHSA-955p-gpfx-r66j

## What is CVE-2025-32394?

CVE-2025-32394 is a medium-severity denial of service vulnerability in Significant-Gravitas AutoGPT, published on 26 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. Prior to 0.6.32, there is a DoS vulnerability in AITextSummarizerBlock. Malicious users can amplify their input. For example, if a malicious user inputs 10K of content, the server will consume 50G of memory, eventually causing memory resources to be exhausted, resulting in DoS. This vulnerability is fixed in 0.6.32.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-405 (Asymmetric Resource Consumption (Amplification))

## Which versions are affected by CVE-2025-32394?


## How do I fix CVE-2025-32394?

No fix has been published for CVE-2025-32394 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-32394 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32394 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32394 and fix it if it is affected.

What it is: CVE-2025-32394 is a medium-severity denial of service vulnerability in Significant-Gravitas AutoGPT, published on 26 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32394 exists.

Affected product: Significant-Gravitas AutoGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32394/ (Markdown: https://insights.sbomify.com/CVE-2025-32394/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32394
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32394
- OSV: https://osv.dev/vulnerability/CVE-2025-32394

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32394/
Summaries are generated and may contain mistakes; the official description above is the record.
