CVE-2025-32395 Vite has an `server.fs.deny` bypass with an invalid `request-target`
An attacker can bypass file access restrictions to read arbitrary files if the Vite dev server is exposed to the network on Node or Bun.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-32395?
CVE-2025-32395 is a medium-severity path traversal vulnerability in vitejs vite, published on 10 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Vite is a frontend tooling framework for javascript. Prior to 6.2.6, 6.1.5, 6.0.15, 5.4.18, and 4.5.13, the contents of arbitrary files can be returned to the browser if the dev server is running on Node or Bun. HTTP 1.1 spec (RFC 9112) does not allow # in request-target. Although an attacker can send such a request. For those requests with an invalid request-line (it includes request-target), the spec recommends to reject them with 400 or 301. The same can be said for HTTP 2. On Node and Bun, those requests are not rejected internally and is passed to the user land. For those requests, the value of http.IncomingMessage.url contains #. Vite assumed req.url won't contain # when checking server.fs.deny, allowing those kinds of requests to bypass the check. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) and running the Vite dev server on runtimes that are not Deno (e.g. Node, Bun) are affected. This vulnerability is fixed in 6.2.6, 6.1.5, 6.0.15, 5.4.18, and 4.5.13.
Weakness: CWE-200
Which versions are affected by CVE-2025-32395?
10 open source packages ship an affected version, including vite.
| Package | Affected | Fixed in |
|---|---|---|
vite npm | All versions | 4.5.13 |
vite npm | All versions | 4.5.13 |
vite npm | From 5.0.0 | 5.4.18 |
vite npm | From 5.0.0 | 5.4.18 |
vite npm | From 6.0.0 | 6.0.15 |
vite npm | From 6.0.0 | 6.0.15 |
4 more packages
vite npm | From 6.1.0 | 6.1.5 |
vite npm | From 6.1.0 | 6.1.5 |
vite npm | From 6.2.0 | 6.2.6 |
vite npm | From 6.2.0 | 6.2.6 |
How do I fix CVE-2025-32395?
Upgrade vite to a fixed version for your release line: 4.5.13, 5.4.18, 6.0.15 or 6.1.5.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-32395 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32395 exists.
Public exploit code: 1 Nuclei template and 1 proofs of concept on GitHub.
Sources
Also known as GHSA-356w-63v5-8wf4, MINI-gj3j-5rm2-7vp2.