CVE-2025-32414 Memory corruption in libxml2

Medium 5.6 Published Updated

Out-of-bounds memory access in libxml2 Python bindings allows attackers to cause denial of service or execute arbitrary code.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-32414?

CVE-2025-32414 is a medium-severity memory corruption vulnerability in Xmlsoft Libxml2, published on 8 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

In libxml2 before 2.13.8 and 2.14.x before 2.14.2, out-of-bounds memory access can occur in the Python API (Python bindings) because of an incorrect return value. This occurs in xmlPythonFileRead and xmlPythonFileReadRaw because of a difference between bytes and characters.

Weakness: CWE-252, CWE-393

Which versions are affected by CVE-2025-32414?

3 open source packages ship an affected version, including java, java-min and jre. It affects 1 product.

PackageAffectedFixed in
java BitnamiAll versions1.8.0, 8.0.461
java-min BitnamiAll versions1.8.0, 8.0.461
jre BitnamiAll versions1.8.0, 8.0.461
Linux distribution packages (13)
libxml2 AlmaLinux:8All versions2.9.7-20.el8_10
libxml2-devel AlmaLinux:8All versions2.9.7-20.el8_10
python3-libxml2 AlmaLinux:8All versions2.9.7-20.el8_10
libxml2-debuginfo Red Hat:enterprise_linux:8::appstreamAll versions0:2.9.7-20.el8_10
libxml2-debugsource Red Hat:enterprise_linux:8::appstreamAll versions0:2.9.7-20.el8_10
libxml2-devel Red Hat:enterprise_linux:8::appstreamAll versions0:2.9.7-20.el8_10
python3-libxml2-debuginfo Red Hat:enterprise_linux:8::appstreamAll versions0:2.9.7-20.el8_10
libxml2 Red Hat:enterprise_linux:8::baseosAll versions0:2.9.7-20.el8_10
libxml2-debuginfo Red Hat:enterprise_linux:8::baseosAll versions0:2.9.7-20.el8_10
libxml2-debugsource Red Hat:enterprise_linux:8::baseosAll versions0:2.9.7-20.el8_10
python3-libxml2 Red Hat:enterprise_linux:8::baseosAll versions0:2.9.7-20.el8_10
python3-libxml2-debuginfo Red Hat:enterprise_linux:8::baseosAll versions0:2.9.7-20.el8_10
libxml2 Rocky Linux:8All versions0:2.9.7-20.el8_10

Products include Xmlsoft Libxml2.

How do I fix CVE-2025-32414?

Upgrade java to a fixed version for your release line: 1.8.0 or 8.0.461.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-32414 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32414 exists.

All Xmlsoft Libxml2 vulnerabilities

Sources

Also known as ALPINE-CVE-2025-32414, ALSA-2025:8958, AZL-59722, AZL-59740, BELL-CVE-2025-32414, BIT-java-2025-32414 and 14 more.

Is CVE-2025-32414 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free