# CVE-2025-32414: Memory corruption in libxml2

> Out-of-bounds memory access in libxml2 Python bindings allows attackers to cause denial of service or execute arbitrary code.

- **Severity:** Medium 5.6 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Apr 2025
- **Updated:** 3 Nov 2025
- **Also known as:** ALPINE-CVE-2025-32414, ALSA-2025:8958, AZL-59722, AZL-59740, BELL-CVE-2025-32414, BIT-java-2025-32414, BIT-java-min-2025-32414, BIT-jre-2025-32414, CLSA-2025-1751889153, DEBIAN-CVE-2025-32414, ECHO-b4ed-0c33-7a11, GHSA-mfrm-w63c-3x58, JLSEC-2025-89, MINI-846p-x735-72j3, OESA-2025-1536, OESA-2025-1537, OESA-2025-1538, RHSA-2025:8958, RLSA-2025:8958, UBUNTU-CVE-2025-32414

## What is CVE-2025-32414?

CVE-2025-32414 is a medium-severity memory corruption vulnerability in Xmlsoft Libxml2, published on 8 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In libxml2 before 2.13.8 and 2.14.x before 2.14.2, out-of-bounds memory access can occur in the Python API (Python bindings) because of an incorrect return value. This occurs in xmlPythonFileRead and xmlPythonFileReadRaw because of a difference between bytes and characters.

Weakness: CWE-252 (Unchecked Return Value), CWE-393 (Return of Wrong Status Code)

## Which versions are affected by CVE-2025-32414?

3 open source packages ship an affected version, including java, java-min and jre. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.8.0, 8.0.461 |
| `java-min` | Bitnami | All versions | 1.8.0, 8.0.461 |
| `jre` | Bitnami | All versions | 1.8.0, 8.0.461 |
| `libxml2` | AlmaLinux:8 | All versions | 2.9.7-20.el8_10 |
| `libxml2-devel` | AlmaLinux:8 | All versions | 2.9.7-20.el8_10 |
| `python3-libxml2` | AlmaLinux:8 | All versions | 2.9.7-20.el8_10 |
| `libxml2-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.9.7-20.el8_10 |
| `libxml2-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.9.7-20.el8_10 |
| `libxml2-devel` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.9.7-20.el8_10 |
| `python3-libxml2-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.9.7-20.el8_10 |
| `libxml2` | Red Hat:enterprise_linux:8::baseos | All versions | 0:2.9.7-20.el8_10 |
| `libxml2-debuginfo` | Red Hat:enterprise_linux:8::baseos | All versions | 0:2.9.7-20.el8_10 |
| `libxml2-debugsource` | Red Hat:enterprise_linux:8::baseos | All versions | 0:2.9.7-20.el8_10 |
| `python3-libxml2` | Red Hat:enterprise_linux:8::baseos | All versions | 0:2.9.7-20.el8_10 |
| `python3-libxml2-debuginfo` | Red Hat:enterprise_linux:8::baseos | All versions | 0:2.9.7-20.el8_10 |
| `libxml2` | Rocky Linux:8 | All versions | 0:2.9.7-20.el8_10 |

Products: Xmlsoft Libxml2.

## How do I fix CVE-2025-32414?

Upgrade java to a fixed version for your release line: 1.8.0 or 8.0.461.

## Is CVE-2025-32414 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32414 exists.

## Other vulnerabilities in Xmlsoft Libxml2

- [CVE-2017-16931](https://insights.sbomify.com/CVE-2017-16931/): XML external entity in n/a (critical 9.8)
- [CVE-2017-8872](https://insights.sbomify.com/CVE-2017-8872/): Information disclosure in n/a (critical 9.1)
- [CVE-2022-49043](https://insights.sbomify.com/CVE-2022-49043/): Use after free in libxml2 (high 8.1)
- [CVE-2026-86140](https://insights.sbomify.com/CVE-2026-86140/): Memory corruption in libxml2 (high 8.0)
- [CVE-2024-34459](https://insights.sbomify.com/CVE-2024-34459/): Memory corruption in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32414 and fix it if it is affected.

What it is: CVE-2025-32414 is a medium-severity memory corruption vulnerability in Xmlsoft Libxml2, published on 8 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32414 exists.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461
- java-min (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461
- jre (Bitnami): affected all versions; fixed in 1.8.0, 8.0.461

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32414/ (Markdown: https://insights.sbomify.com/CVE-2025-32414/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32414
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32414
- OSV: https://osv.dev/vulnerability/CVE-2025-32414

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32414/
Summaries are generated and may contain mistakes; the official description above is the record.
