{"answers":{"affected":"2 open source packages ship an affected version, including verbb/formie. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-32427 in the wild and no public exploit code.","fix":"Upgrade verbb/formie to 2.1.44 or later.","what":"CVE-2025-32427 is a medium-severity cross-site scripting vulnerability in verbb formie, published on 11 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-32427 and fix it if it is affected.\n\nWhat it is: CVE-2025-32427 is a medium-severity cross-site scripting vulnerability in verbb formie, published on 11 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-32427 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- verbb/formie (Packagist): affected all versions; fixed in 2.1.44\n- verbb/formie (Packagist): affected all versions; fixed in 2.1.44\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32427/ (Markdown: https://insights.sbomify.com/CVE-2025-32427/index.md)","id":"CVE-2025-32427","markdown":"https://insights.sbomify.com/CVE-2025-32427/index.md","name":"CVE-2025-32427","record":{"aliases":["GHSA-p9hh-mh5x-wvx3"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Craft CMS plugin","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the admin interface by tampering with JSON form imports in Formie.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"formie","vendor":"verbb"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Formie is a Craft CMS plugin for creating forms. Prior to 2.1.44, when importing a form from JSON, if the field label or handle contained malicious content, the output wasn't correctly escaped when viewing a preview of what was to be imported. As imports are undertaking primarily by users who have themselves exported the form from one environment to another, and would require direct manipulation of the JSON export, this is marked as moderate. This vulnerability will not occur unless someone deliberately tampers with the export. This vulnerability is fixed in 2.1.44.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Formie has a XSS vulnerability for importing forms","id":"CVE-2025-32427","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Jupyter Remote Desktop Proxy makes TigerVNC accessible via the network and not just via a UNIX socket as intended","id":"CVE-2025-32428"},"packages":[{"ecosystem":"Packagist","fixed":["2.1.44"],"introduced":["0"],"last_affected":[],"package":"verbb/formie","purl":null,"source":"GHSA-p9hh-mh5x-wvx3"},{"ecosystem":"Packagist","fixed":["2.1.44"],"introduced":["0"],"last_affected":[],"package":"verbb/formie","purl":"pkg:composer/verbb/formie","source":"GHSA-p9hh-mh5x-wvx3"}],"prev":{"headline":"Formie has a XSS vulnerability for email notification content for preview","id":"CVE-2025-32426"},"products":["formie"],"published":"2025-04-11","related":[{"cvss_score":4.6,"headline":"Formie has a XSS vulnerability for email notification content for preview","id":"CVE-2025-32426","kev_date_added":null,"published":"2025-04-11"},{"cvss_score":4.4,"headline":"verbb/formie Server-Side Template Injection for variable-enabled settings","id":"CVE-2024-35191","kev_date_added":null,"published":"2024-05-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-11","vendors":["verbb"]},"summary":"An attacker can execute arbitrary scripts in the admin interface by tampering with JSON form imports in Formie.","url":"https://insights.sbomify.com/CVE-2025-32427/"}