# CVE-2025-32427: Formie has a XSS vulnerability for importing forms

> An attacker can execute arbitrary scripts in the admin interface by tampering with JSON form imports in Formie.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Apr 2025
- **Updated:** 11 Apr 2025
- **Also known as:** GHSA-p9hh-mh5x-wvx3

## What is CVE-2025-32427?

CVE-2025-32427 is a medium-severity cross-site scripting vulnerability in verbb formie, published on 11 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Formie is a Craft CMS plugin for creating forms. Prior to 2.1.44, when importing a form from JSON, if the field label or handle contained malicious content, the output wasn't correctly escaped when viewing a preview of what was to be imported. As imports are undertaking primarily by users who have themselves exported the form from one environment to another, and would require direct manipulation of the JSON export, this is marked as moderate. This vulnerability will not occur unless someone deliberately tampers with the export. This vulnerability is fixed in 2.1.44.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-32427?

2 open source packages ship an affected version, including verbb/formie. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `verbb/formie` | Packagist | All versions | 2.1.44 |
| `verbb/formie` | Packagist | All versions | 2.1.44 |

Products: Verbb Formie.

## How do I fix CVE-2025-32427?

Upgrade verbb/formie to 2.1.44 or later.

## Is CVE-2025-32427 being exploited?

There is no known exploitation of CVE-2025-32427 in the wild and no public exploit code.

## Other vulnerabilities in verbb formie

- [CVE-2025-32426](https://insights.sbomify.com/CVE-2025-32426/): Formie has a XSS vulnerability for email notification content for preview (medium 4.6)
- [CVE-2024-35191](https://insights.sbomify.com/CVE-2024-35191/): verbb/formie Server-Side Template Injection for variable-enabled settings (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32427 and fix it if it is affected.

What it is: CVE-2025-32427 is a medium-severity cross-site scripting vulnerability in verbb formie, published on 11 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-32427 in the wild and no public exploit code.

Affected packages and fixed versions:
- verbb/formie (Packagist): affected all versions; fixed in 2.1.44
- verbb/formie (Packagist): affected all versions; fixed in 2.1.44

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32427/ (Markdown: https://insights.sbomify.com/CVE-2025-32427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32427
- OSV: https://osv.dev/vulnerability/CVE-2025-32427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32427/
Summaries are generated and may contain mistakes; the official description above is the record.
