# CVE-2025-32428: Jupyter Remote Desktop Proxy makes TigerVNC accessible via the network and not just via a UNIX socket as intended

> Attackers can access TigerVNC sessions over the network instead of just via UNIX sockets, bypassing intended access controls in Jupyter Remote Desktop Proxy.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2025
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-vrq4-9hc3-cgp7, PYSEC-2026-365

## What is CVE-2025-32428?

CVE-2025-32428 is a critical vulnerability in jupyterhub jupyter-remote-desktop-proxy, published on 14 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Jupyter Remote Desktop Proxy allows you to run a Linux Desktop on a JupyterHub. jupyter-remote-desktop-proxy was meant to rely on UNIX sockets readable only by the current user since version 3.0.0, but when used with TigerVNC, the VNC server started by jupyter-remote-desktop-proxy were still accessible via the network. This vulnerability does not affect users having TurboVNC as the vncserver executable. This issue is fixed in 3.0.1.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2025-32428?

3 open source packages ship an affected version, including jupyter-remote-desktop-proxy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-remote-desktop-proxy` | PyPI | From 3.0.0 | 3.0.1 |
| `jupyter-remote-desktop-proxy` | PyPI | From 3.0.0 | 3.0.1 |
| `jupyter-remote-desktop-proxy` | PyPI | From 3.0.0 | 3.0.1 |

## How do I fix CVE-2025-32428?

Upgrade jupyter-remote-desktop-proxy to 3.0.1 or later.

## Is CVE-2025-32428 being exploited?

There is no known exploitation of CVE-2025-32428 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32428 and fix it if it is affected.

What it is: CVE-2025-32428 is a critical vulnerability in jupyterhub jupyter-remote-desktop-proxy, published on 14 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32428 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-remote-desktop-proxy (PyPI): affected from 3.0.0; fixed in 3.0.1
- jupyter-remote-desktop-proxy (PyPI): affected from 3.0.0; fixed in 3.0.1
- jupyter-remote-desktop-proxy (PyPI): affected from 3.0.0; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32428/ (Markdown: https://insights.sbomify.com/CVE-2025-32428/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32428
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32428
- OSV: https://osv.dev/vulnerability/CVE-2025-32428

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32428/
Summaries are generated and may contain mistakes; the official description above is the record.
