# CVE-2025-32429: XWiki Platform vulnerable to SQL injection through getdeleteddocuments.vm template sort parameter

> Attackers can inject SQL via the sort parameter in the getdeleteddocuments.vm template, allowing unauthorized data access or modification in XWiki Platform.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2025
- **Updated:** 25 Jul 2025
- **Also known as:** GHSA-vr59-gm53-v7cq

## What is CVE-2025-32429?

CVE-2025-32429 is a critical SQL injection vulnerability in Xwiki Xwiki, published on 24 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In versions 9.4-rc-1 through 16.10.5 and 17.0.0-rc-1 through 17.2.2, it's possible for anyone to inject SQL using the parameter sort of the getdeleteddocuments.vm. It's injected as is as an ORDER BY value. This is fixed in versions 16.10.6 and 17.3.0-rc-1.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-32429?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-distribution-war. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 17.0.0-rc-1 | 17.3.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 17.0.0-rc-1 | 17.3.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 9.4-rc-1 | 16.10.6 |
| `org.xwiki.platform:xwiki-platform-distribution-war` | Maven | From 9.4-rc-1 | 16.10.6 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-32429?

Upgrade org.xwiki.platform:xwiki-platform-distribution-war to a fixed version for your release line: 17.3.0-rc-1 or 16.10.6.

## Is CVE-2025-32429 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32429 exists.

Public exploit code:

- Exploit for CVE-2025-32429 – SQLi in XWiki REST API (getdeleteddocuments.vm). (github_poc): https://github.com/byteReaper77/CVE-2025-32429
- Proof-of-Concept exploit for CVE-2025-32429 (SQL Injection in PHP PDO prepared statements) – for educational and security research purposes only (github_poc): https://github.com/amir-othman/CVE-2025-32429
- XWiki 14 - SQL Injection via getdeleteddocuments.vm (exploitdb)
- https://github.com/imbas007/CVE-2025-32429-Checker (github_poc): https://github.com/imbas007/CVE-2025-32429-Checker
- XWiki Platform - SQL Injection (nuclei): http/cves/2025/CVE-2025-32429.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32429 and fix it if it is affected.

What it is: CVE-2025-32429 is a critical SQL injection vulnerability in Xwiki Xwiki, published on 24 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32429 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 17.0.0-rc-1; fixed in 17.3.0-rc-1
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 17.0.0-rc-1; fixed in 17.3.0-rc-1
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 9.4-rc-1; fixed in 16.10.6
- org.xwiki.platform:xwiki-platform-distribution-war (Maven): affected from 9.4-rc-1; fixed in 16.10.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32429/ (Markdown: https://insights.sbomify.com/CVE-2025-32429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32429
- OSV: https://osv.dev/vulnerability/CVE-2025-32429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32429/
Summaries are generated and may contain mistakes; the official description above is the record.
