CVE-2025-32430 XWiki Platform contains Reflected XSS vulnerability in two templates
Attackers can execute malicious JavaScript in victim sessions via reflected XSS in XWiki templates, enabling arbitrary actions with victim permissions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-32430?
CVE-2025-32430 is a medium-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In versions 4.2-milestone-3 through 16.4.7, 16.5.0-rc-1 through 16.10.5 and 17.0.0-rc-1 through 17.2.2, two templates contain reflected XSS vulnerabilities, allowing an attacker to execute malicious JavaScript code in the context of the victim's session by getting the victim to visit an attacker-controlled URL. This permits the attacker to perform arbitrary actions using the permissions of the victim. This issue is fixed in versions 16.4.8, 16.10.6 and 17.3.0-rc-1. To workaround the issue, manually patch the WAR with the same changes as the original patch.
Weakness: CWE-79
Which versions are affected by CVE-2025-32430?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web-templates. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-web-templates Maven | From 16.5.0-rc-1 | 16.10.6 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 16.5.0-rc-1 | 16.10.6 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 17.0.0-rc-1 | 17.3.0-rc-1 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 17.0.0-rc-1 | 17.3.0-rc-1 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 4.2-milestone-3 | 16.4.8 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 4.2-milestone-3 | 16.4.8 |
Products include Xwiki Xwiki.
How do I fix CVE-2025-32430?
Upgrade org.xwiki.platform:xwiki-platform-web-templates to a fixed version for your release line: 16.10.6, 17.3.0-rc-1 or 16.4.8.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-32430 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32430 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-m9x4-w7p9-mxhx.