# CVE-2025-32430: XWiki Platform contains Reflected XSS vulnerability in two templates

> Attackers can execute malicious JavaScript in victim sessions via reflected XSS in XWiki templates, enabling arbitrary actions with victim permissions.

- **Severity:** Medium 6.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Aug 2025
- **Updated:** 6 Aug 2025
- **Also known as:** GHSA-m9x4-w7p9-mxhx

## What is CVE-2025-32430?

CVE-2025-32430 is a medium-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. In versions 4.2-milestone-3 through 16.4.7, 16.5.0-rc-1 through 16.10.5 and 17.0.0-rc-1 through 17.2.2, two templates contain reflected XSS vulnerabilities, allowing an attacker to execute malicious JavaScript code in the context of the victim's session by getting the victim to visit an attacker-controlled URL. This permits the attacker to perform arbitrary actions using the permissions of the victim. This issue is fixed in versions 16.4.8, 16.10.6 and 17.3.0-rc-1. To workaround the issue, manually patch the WAR with the same changes as the original patch.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-32430?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web-templates. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 16.5.0-rc-1 | 16.10.6 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 16.5.0-rc-1 | 16.10.6 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 17.0.0-rc-1 | 17.3.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 17.0.0-rc-1 | 17.3.0-rc-1 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 4.2-milestone-3 | 16.4.8 |
| `org.xwiki.platform:xwiki-platform-web-templates` | Maven | From 4.2-milestone-3 | 16.4.8 |

Products: Xwiki Xwiki.

## How do I fix CVE-2025-32430?

Upgrade org.xwiki.platform:xwiki-platform-web-templates to a fixed version for your release line: 16.10.6, 17.3.0-rc-1 or 16.4.8.

## Is CVE-2025-32430 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32430 exists.

Public exploit code:

- XWiki Platform - Cross-Site Scripting (nuclei): http/cves/2025/CVE-2025-32430.yaml

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32430 and fix it if it is affected.

What it is: CVE-2025-32430 is a medium-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 5 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32430 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 16.5.0-rc-1; fixed in 16.10.6
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 16.5.0-rc-1; fixed in 16.10.6
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 17.0.0-rc-1; fixed in 17.3.0-rc-1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 17.0.0-rc-1; fixed in 17.3.0-rc-1
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 4.2-milestone-3; fixed in 16.4.8
- org.xwiki.platform:xwiki-platform-web-templates (Maven): affected from 4.2-milestone-3; fixed in 16.4.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32430/ (Markdown: https://insights.sbomify.com/CVE-2025-32430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32430
- OSV: https://osv.dev/vulnerability/CVE-2025-32430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32430/
Summaries are generated and may contain mistakes; the official description above is the record.
