# CVE-2025-32432: Craft CMS Code Injection

> Craft CMS allows remote code execution via a high-impact, low-complexity attack vector, requiring immediate patching.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Yes, since 20 Mar 2026 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2025
- **Updated:** 21 Mar 2026
- **Also known as:** GHSA-f3gw-9ww9-jmc3

## What is CVE-2025-32432?

CVE-2025-32432 is a critical code injection vulnerability in Craftcms Craft Cms, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-32432?

6 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 3.0.0-RC1 | 3.9.15 |
| `craftcms/cms` | Packagist | From 3.0.0-RC1 | 3.9.15 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.14.15 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.14.15 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.6.17 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.6.17 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2025-32432?

Upgrade craftcms/cms to a fixed version for your release line: 3.9.15, 4.14.15 or 5.6.17. US federal agencies must fix it by 3 Apr 2026.

## Is CVE-2025-32432 being exploited?

Yes. Attackers have exploited CVE-2025-32432 in the wild since at least 20 Mar 2026.

Public exploit code:

- This repository contains a proof-of-concept exploit script for CVE-2025-32432, a pre-authentication Remote Code Execution (RCE) vulnerability affecting CraftCMS versions 4.x and 5.x. The vulnerability exists in the asset transform generation feature of CraftCMS. (github_poc): https://github.com/Sachinart/CVE-2025-32432
- CraftCMS RCE Checker (CVE-2025-32432) (github_poc): https://github.com/Chocapikk/CVE-2025-32432
- https://github.com/CTY-Research-1/CVE-2025-32432-PoC (github_poc): https://github.com/CTY-Research-1/CVE-2025-32432-PoC
- Reliable CVE-2025-32432 pre-auth RCE exploit for Craft CMS 3.x/4.x/5.x, works where other public PoCs fail (github_poc): https://github.com/P34NUT2/CVE-2025-32432-exploit-by-P34NUT
- Exploit, POC for CVE-2025-32432, CraftCMS2Shell (github_poc): https://github.com/c0gnit00/CVE-2025-32432
- AI修复生成的CVE-2025-32432的poc (github_poc): https://github.com/bambooqj/CVE-2025-32432

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)
- [CVE-2021-27903](https://insights.sbomify.com/CVE-2021-27903/): Craft CMS Remote Code Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32432 and fix it if it is affected.

What it is: CVE-2025-32432 is a critical code injection vulnerability in Craftcms Craft Cms, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2025-32432 in the wild since at least 20 Mar 2026.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 3.0.0-RC1; fixed in 3.9.15
- craftcms/cms (Packagist): affected from 3.0.0-RC1; fixed in 3.9.15
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.14.15
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.14.15
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.6.17
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.6.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32432/ (Markdown: https://insights.sbomify.com/CVE-2025-32432/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32432
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32432
- OSV: https://osv.dev/vulnerability/CVE-2025-32432

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32432/
Summaries are generated and may contain mistakes; the official description above is the record.
