# CVE-2025-32433: Erlang Erlang/OTP SSH Server Missing Authentication for Critical Function

> Attackers can execute arbitrary code remotely without authentication by exploiting a flaw in the Erlang/OTP SSH server's protocol handling.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 9 Jun 2025 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2025
- **Updated:** 26 Feb 2026
- **Also known as:** AZL-60441, AZL-60583, CLEANSTART-2026-RU46507, DEBIAN-CVE-2025-32433, GHSA-37cp-fgq5-7wc2, OESA-2025-1461, SUSE-SU-2025:1357-1, UBUNTU-CVE-2025-32433, USN-7443-1, USN-7443-2, USN-7443-3

## What is CVE-2025-32433?

CVE-2025-32433 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 16 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Erlang/OTP is a set of libraries for the Erlang programming language. Prior to versions OTP-27.3.3, OTP-26.2.5.11, and OTP-25.3.2.20, a SSH server may allow an attacker to perform unauthenticated remote code execution (RCE). By exploiting a flaw in SSH protocol message handling, a malicious actor could gain unauthorized access to affected systems and execute arbitrary commands without valid credentials. This issue is patched in versions OTP-27.3.3, OTP-26.2.5.11, and OTP-25.3.2.20. A temporary workaround involves disabling the SSH server or to prevent access via firewall rules.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2025-32433?

It affects 23 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `erlang` | SUSE:Enterprise Storage 7.1 | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Manager Proxy 4.3 | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | SUSE:Manager Server 4.3 | All versions | 23.3.4.19-150300.3.20.1 |
| `erlang` | openSUSE:Leap 15.6 | All versions | 23.3.4.19-150300.3.20.1 |

Products: Cisco Cloud Native Broadband Network Gateway, Cisco Confd Basic, Cisco Enterprise Nfv Infrastructure Software, Cisco Inode Manager, Cisco Ncs 2000 Shelf Virtualization Orchestrator Firmware, Cisco Network Services Orchestrator, Cisco Optical Site Manager, Cisco Rv160 Firmware, Cisco Rv160w Firmware, Cisco Rv260 Firmware, Cisco Rv260p Firmware, Cisco Rv260w Firmware, Cisco Rv340 Firmware, Cisco Rv340w Firmware, Cisco Rv345 Firmware, Cisco Rv345p Firmware, Cisco Smart Phy, Cisco Staros, Cisco Ultra Cloud Core, Cisco Ultra Packet Core and 3 more.

## How do I fix CVE-2025-32433?

Upgrade to a fixed version. US federal agencies must fix it by 30 Jun 2025.

## Is CVE-2025-32433 being exploited?

Yes. Attackers have exploited CVE-2025-32433 in the wild since at least 9 Jun 2025.

Public exploit code:

- CVE-2025-32433 https://github.com/erlang/otp/security/advisories/GHSA-37cp-fgq5-7wc2 (github_poc): https://github.com/ProDefense/CVE-2025-32433
- The vulnerability allows an attacker with network access to an Erlang/OTP SSH server to execute arbitrary code without prior authentication. (github_poc): https://github.com/omer-efe-curkus/CVE-2025-32433-Erlang-OTP-SSH-RCE-PoC
- python script to find vulnerable targets of CVE-2025-32433  (github_poc): https://github.com/m0usem0use/erl_mouse
- CVE-2025-32433 PoC: Unauthenticated Remote Code Execution (RCE) in Erlang/OTP SSH. A proof-of-concept exploit for CVE-2025-32433 (github_poc): https://github.com/NiteeshPujari/CVE-2025-32433-PoC
- https://github.com/0xPThree/cve-2025-32433 (github_poc): https://github.com/0xPThree/cve-2025-32433
- https://github.com/ekomsSavior/POC_CVE-2025-32433 (github_poc): https://github.com/ekomsSavior/POC_CVE-2025-32433

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32433 and fix it if it is affected.

What it is: CVE-2025-32433 is a critical authentication bypass vulnerability in Debian Debian Linux, published on 16 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2025-32433 in the wild since at least 9 Jun 2025.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32433/ (Markdown: https://insights.sbomify.com/CVE-2025-32433/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32433
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32433
- OSV: https://osv.dev/vulnerability/CVE-2025-32433

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32433/
Summaries are generated and may contain mistakes; the official description above is the record.
