# CVE-2025-32434: PyTorch: `torch.load` with `weights_only=True` leads to remote code execution

> Attackers can achieve remote code execution by tricking users into loading malicious models with weights_only enabled in PyTorch.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2025
- **Updated:** 1 Dec 2025
- **Also known as:** AZL-60877, AZL-60880, BIT-pytorch-2025-32434, CLSA-2025-1760660047, DEBIAN-CVE-2025-32434, DLA-4389-1, GHSA-53q9-r3pm-6pq6, PYSEC-2025-41

## What is CVE-2025-32434?

CVE-2025-32434 is a critical unsafe deserialization vulnerability in pytorch, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyTorch is a Python package that provides tensor computation with strong GPU acceleration and deep neural networks built on a tape-based autograd system. In version 2.5.1 and prior, a Remote Command Execution (RCE) vulnerability exists in PyTorch when loading a model using torch.load with weights_only=True. This issue has been patched in version 2.6.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-32434?

4 open source packages ship an affected version, including pytorch and torch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pytorch` | Bitnami | All versions | 2.6.0 |
| `torch` | PyPI | All versions | 2.6.0 |
| `torch` | PyPI | All versions | 2.6.0 |
| `torch` | PyPI | All versions | 2.6.0 |

Products: Linuxfoundation Pytorch.

## How do I fix CVE-2025-32434?

Upgrade pytorch to 2.6.0 or later.

## Is CVE-2025-32434 being exploited?

There is no known exploitation of CVE-2025-32434 in the wild and no public exploit code.

Public exploit code:

- https://github.com/AlexanderGumeniuk/CVE-2025-32434 (github_poc): https://github.com/AlexanderGumeniuk/CVE-2025-32434
- A script for exploiting a vulnerability in PyTorch with subsequent RCE in library versions < 2.6.0 (github_poc): https://github.com/B1tBit/CVE-2025-32434-exploit
- https://github.com/cyhe50/cve-2025-32434-poc (github_poc): https://github.com/cyhe50/cve-2025-32434-poc
- An automated, high-precision zero-shot evaluation pipeline for OpenAI's CLIP model on CIFAR-10. Features 88.80% accuracy, Safetensors security mitigation (CVE-2025-32434), and AI Native (Trae) workflow. (github_poc): https://github.com/Soildworks/Agentic-CLIP-Benchmark

## Other vulnerabilities in pytorch

- [CVE-2024-48063](https://insights.sbomify.com/CVE-2024-48063/): Deserialization in n/a (critical 9.8)
- [CVE-2022-45907](https://insights.sbomify.com/CVE-2022-45907/): PyTorch vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2026-24747](https://insights.sbomify.com/CVE-2026-24747/): PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files (high 8.8)
- [CVE-2024-31583](https://insights.sbomify.com/CVE-2024-31583/): Pytorch use-after-free vulnerability (high 7.8)
- [CVE-2025-55551](https://insights.sbomify.com/CVE-2025-55551/): Denial of service in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32434 and fix it if it is affected.

What it is: CVE-2025-32434 is a critical unsafe deserialization vulnerability in pytorch, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32434 in the wild and no public exploit code.

Affected packages and fixed versions:
- pytorch (Bitnami): affected all versions; fixed in 2.6.0
- torch (PyPI): affected all versions; fixed in 2.6.0
- torch (PyPI): affected all versions; fixed in 2.6.0
- torch (PyPI): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32434/ (Markdown: https://insights.sbomify.com/CVE-2025-32434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32434
- OSV: https://osv.dev/vulnerability/CVE-2025-32434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32434/
Summaries are generated and may contain mistakes; the official description above is the record.
