# CVE-2025-32439: pleezer allows resource exhaustion through uncollected hook script processes

> Attackers can cause resource exhaustion and prevent new process creation by triggering rapid playback events in the pleezer player.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2025
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-472w-7w45-g3w5

## What is CVE-2025-32439?

CVE-2025-32439 is a medium-severity denial of service vulnerability in roderickvd pleezer, published on 15 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pleezer is a headless Deezer Connect player. Hook scripts in pleezer can be triggered by various events like track changes and playback state changes. In versions before 0.16.0, these scripts were spawned without proper process cleanup, leaving zombie processes in the system's process table. Even during normal usage, every track change and playback event would leave behind zombie processes. This leads to inevitable resource exhaustion over time as the system's process table fills up, eventually preventing new processes from being created. The issue is exacerbated if events occur rapidly, whether through normal use (e.g., skipping through a playlist) or potential manipulation of the Deezer Connect protocol traffic. This issue has been fixed in version 0.16.0.

Weakness: CWE-460 (Improper Cleanup on Thrown Exception)

## Which versions are affected by CVE-2025-32439?

2 open source packages ship an affected version, including pleezer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pleezer` | crates.io | All versions | 0.16.0 |
| `pleezer` | crates.io | All versions | 0.16.0 |

## How do I fix CVE-2025-32439?

Upgrade pleezer to 0.16.0 or later.

## Is CVE-2025-32439 being exploited?

There is no known exploitation of CVE-2025-32439 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32439 and fix it if it is affected.

What it is: CVE-2025-32439 is a medium-severity denial of service vulnerability in roderickvd pleezer, published on 15 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32439 in the wild and no public exploit code.

Affected packages and fixed versions:
- pleezer (crates.io): affected all versions; fixed in 0.16.0
- pleezer (crates.io): affected all versions; fixed in 0.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32439/ (Markdown: https://insights.sbomify.com/CVE-2025-32439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32439
- OSV: https://osv.dev/vulnerability/CVE-2025-32439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32439/
Summaries are generated and may contain mistakes; the official description above is the record.
