# CVE-2025-32440: NetAlertX Vulnerable to Authentication Bypass

> Attackers can bypass authentication to modify settings and trigger sensitive functions in NetAlertX network scanner.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 May 2025
- **Updated:** 28 May 2025
- **Also known as:** GHSA-h4x5-vr54-vjrx

## What is CVE-2025-32440?

CVE-2025-32440 is a critical authentication bypass vulnerability in jokob-sk NetAlertX, published on 27 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NetAlertX is a network, presence scanner and alert framework. Prior to version 25.4.14, it is possible to bypass the authentication mechanism of NetAlertX to update settings without authentication. An attacker can trigger sensitive functions within util.php by sending crafted requests to /index.php. This issue has been patched in version 25.4.14.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2025-32440?

It affects 1 product.


Products: Netalertx Netalertx.

## How do I fix CVE-2025-32440?

No fix has been published for CVE-2025-32440 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-32440 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32440 exists.

Public exploit code:

- Verified PoC and replication steps for CVE-2025-32440 (NetAlertX auth bypass) (github_poc): https://github.com/jstjep00/CVE-2025-32440-netalertx-auth-bypass

## Other vulnerabilities in jokob-sk NetAlertX

- [CVE-2024-46506](https://insights.sbomify.com/CVE-2024-46506/): Command injection in NetAlertX (critical 10.0)
- [CVE-2025-48952](https://insights.sbomify.com/CVE-2025-48952/): NetAlertX has Password Bypass Vulnerability due to Loose Comparison in PHP (critical 9.4)
- [CVE-2024-48766](https://insights.sbomify.com/CVE-2024-48766/): Path traversal in NetAlertX (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32440 and fix it if it is affected.

What it is: CVE-2025-32440 is a critical authentication bypass vulnerability in jokob-sk NetAlertX, published on 27 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32440 exists.

Affected product: jokob-sk NetAlertX. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32440/ (Markdown: https://insights.sbomify.com/CVE-2025-32440/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32440
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32440
- OSV: https://osv.dev/vulnerability/CVE-2025-32440

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32440/
Summaries are generated and may contain mistakes; the official description above is the record.
