# CVE-2025-32441: Rack session gets restored after deletion

> Attackers can retain illicit access after user logout via a race condition in Rack session pool, allowing session restoration and potential account takeover.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2025
- **Updated:** 8 May 2025
- **Also known as:** DEBIAN-CVE-2025-32441, GHSA-vpfw-47h7-xj4g, MINI-6f63-rfqm-rq2r, UBUNTU-CVE-2025-32441

## What is CVE-2025-32441?

CVE-2025-32441 is a medium-severity vulnerability in rack, published on 7 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Rack is a modular Ruby web server interface. Prior to version 2.2.14, when using the `Rack::Session::Pool` middleware, simultaneous rack requests can restore a deleted rack session, which allows the unauthenticated user to occupy that session. Rack session middleware prepares the session at the beginning of request, then saves is back to the store with possible changes applied by host rack application. This way the session becomes to be a subject of race conditions in general sense over concurrent rack requests. When using the `Rack::Session::Pool` middleware, and provided the attacker can acquire a session cookie (already a major issue), the session may be restored if the attacker can trigger a long running request (within that same session) adjacent to the user logging out, in order to retain illicit access even after a user has attempted to logout. Version 2.2.14 contains a patch for the issue. Some other mitigations are available. Either ensure the application invalidates sessions atomically by marking them as logged out e.g., using a `logged_out` flag, instead of deleting them, and check this flag on every request to prevent reuse; or implement a custom session store that tracks session invalidation timestamps and refuses to accept session data if the session was invalidated after the request began.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration), CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition), CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2025-32441?

2 open source packages ship an affected version, including rack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.2.14 |
| `rack` | RubyGems | All versions | 2.2.14 |

Products: Rack Rack.

## How do I fix CVE-2025-32441?

Upgrade rack to 2.2.14 or later.

## Is CVE-2025-32441 being exploited?

There is no known exploitation of CVE-2025-32441 in the wild and no public exploit code.

## Other vulnerabilities in rack

- [CVE-2026-34785](https://insights.sbomify.com/CVE-2026-34785/): Rack: Local file inclusion in `Rack::Static` via URL Prefix Matching (high 7.5)
- [CVE-2026-34827](https://insights.sbomify.com/CVE-2026-34827/): Rack: Algorithmic-Complexity DoS in Rack::Multipart::Parser (high 7.5)
- [CVE-2026-34829](https://insights.sbomify.com/CVE-2026-34829/): Rack: Denial of Service via Unbounded Multipart File Upload Without Content-Length (high 7.5)
- [CVE-2026-22860](https://insights.sbomify.com/CVE-2026-22860/): Rack has a Directory Traversal via Rack:Directory (high 7.5)
- [CVE-2025-61919](https://insights.sbomify.com/CVE-2025-61919/): Rack is vulnerable to a memory-exhaustion DoS through unbounded URL-encoded body parsing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32441 and fix it if it is affected.

What it is: CVE-2025-32441 is a medium-severity vulnerability in rack, published on 7 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32441 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.2.14
- rack (RubyGems): affected all versions; fixed in 2.2.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32441/ (Markdown: https://insights.sbomify.com/CVE-2025-32441/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32441
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32441
- OSV: https://osv.dev/vulnerability/CVE-2025-32441

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32441/
Summaries are generated and may contain mistakes; the official description above is the record.
