CVE-2025-32442 Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass

High 7.5 Published Updated

Attackers can bypass input validation in Fastify applications by manipulating content-type headers, requiring specific schema configurations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-32442?

CVE-2025-32442 is a high-severity vulnerability in fastify, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Fastify is a fast and low overhead web framework, for Node.js. In versions 5.0.0 to 5.3.0 as well as version 4.29.0, applications that specify different validation strategies for different content types have a possibility to bypass validation by providing a _slightly altered_ content type such as with different casing or altered whitespacing before `;`. This was patched in v5.3.1, but the initial patch did not cover all problems. This has been fully patched in v5.3.2 and v4.29.1. A workaround involves not specifying individual content types in the schema.

Weakness: CWE-1287

Which versions are affected by CVE-2025-32442?

It affects 1 product.

Products include Fastify Fastify.

How do I fix CVE-2025-32442?

Upgrade to a fixed version.

Is CVE-2025-32442 being exploited?

There is no known exploitation of CVE-2025-32442 in the wild and no public exploit code.

Sources

Is CVE-2025-32442 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free