# CVE-2025-32442: Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass

> Attackers can bypass input validation in Fastify applications by manipulating content-type headers, requiring specific schema configurations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2025
- **Updated:** 22 Aug 2025

## What is CVE-2025-32442?

CVE-2025-32442 is a high-severity vulnerability in fastify, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fastify is a fast and low overhead web framework, for Node.js. In versions 5.0.0 to 5.3.0 as well as version 4.29.0, applications that specify different validation strategies for different content types have a possibility to bypass validation by providing a _slightly altered_ content type such as with different casing or altered whitespacing before `;`. This was patched in v5.3.1, but the initial patch did not cover all problems. This has been fully patched in v5.3.2 and v4.29.1. A workaround involves not specifying individual content types in the schema.

Weakness: CWE-1287 (Improper Validation of Specified Type of Input)

## Which versions are affected by CVE-2025-32442?

It affects 1 product.


Products: Fastify Fastify.

## How do I fix CVE-2025-32442?

Upgrade to a fixed version.

## Is CVE-2025-32442 being exploited?

There is no known exploitation of CVE-2025-32442 in the wild and no public exploit code.

## Other vulnerabilities in fastify

- [CVE-2026-84504](https://insights.sbomify.com/CVE-2026-84504/): fastify vulnerable to request body replacement via an async validation result collision (high 8.1)
- [CVE-2026-76169](https://insights.sbomify.com/CVE-2026-76169/): fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-found handlers (high 7.5)
- [CVE-2026-84428](https://insights.sbomify.com/CVE-2026-84428/): fastify vulnerable to header validation bypass via incomplete schema case normalization (high 7.5)
- [CVE-2026-84469](https://insights.sbomify.com/CVE-2026-84469/): fastify vulnerable to request validation bypass via skipped boolean false schemas (high 7.5)
- [CVE-2026-33806](https://insights.sbomify.com/CVE-2026-33806/): fastify vulnerable to Body Schema Validation Bypass via Leading Space in Content-Type Header (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32442 and fix it if it is affected.

What it is: CVE-2025-32442 is a high-severity vulnerability in fastify, published on 18 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32442 in the wild and no public exploit code.

Affected product: fastify. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32442/ (Markdown: https://insights.sbomify.com/CVE-2025-32442/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32442
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32442
- OSV: https://osv.dev/vulnerability/CVE-2025-32442

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32442/
Summaries are generated and may contain mistakes; the official description above is the record.
