{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-32444 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.8.5 or later.","what":"CVE-2025-32444 is a critical unsafe deserialization vulnerability in Vllm Vllm, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32444 and fix it if it is affected.\n\nWhat it is: CVE-2025-32444 is a critical unsafe deserialization vulnerability in Vllm Vllm, published on 30 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-32444 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.6.5; fixed in 0.8.5\n- vllm (PyPI): affected from 0.6.5; fixed in 0.8.5\n- vllm (PyPI): affected from 0.6.5; fixed in 0.8.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32444/ (Markdown: https://insights.sbomify.com/CVE-2025-32444/index.md)","id":"CVE-2025-32444","markdown":"https://insights.sbomify.com/CVE-2025-32444/index.md","name":"CVE-2025-32444","record":{"aliases":["GHSA-hj4w-hm2g-p6w5","PYSEC-2025-42"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"LLM inference engine","requires_auth":"none","summary":"Attackers can execute arbitrary code on vLLM servers using the Mooncake integration due to unsafe pickle deserialization over exposed ZeroMQ sockets.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. vLLM instances that do not make use of the mooncake integration are not vulnerable. This issue has been patched in version 0.8.5.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":4,"next":{"headline":"Users can gain privileged access to the host system and cluster with EventSource and Sensor CR","id":"CVE-2025-32445"},"packages":[{"ecosystem":"PyPI","fixed":["0.8.5"],"introduced":["0.6.5"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-hj4w-hm2g-p6w5"},{"ecosystem":"PyPI","fixed":["0.8.5"],"introduced":["0.6.5"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-hj4w-hm2g-p6w5"},{"ecosystem":"PyPI","fixed":["0.8.5"],"introduced":["0.6.5"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2025-42"}],"prev":{"headline":"Fastify vulnerable to invalid content-type parsing, which could lead to validation bypass","id":"CVE-2025-32442"},"products":["vllm"],"published":"2025-04-30","related":[{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-30","vendors":["vllm-project"]},"summary":"Attackers can execute arbitrary code on vLLM servers using the Mooncake integration due to unsafe pickle deserialization over exposed ZeroMQ sockets.","url":"https://insights.sbomify.com/CVE-2025-32444/"}