CVE-2025-32461 Code injection in Tiki
Attackers can execute arbitrary code via improper input handling in the includetpl plugin of Tiki Wiki CMS.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-32461?
CVE-2025-32461 is a critical code injection vulnerability in Tiki, published on 9 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
wikiplugin_includetpl in lib/wiki-plugins/wikiplugin_includetpl.php in Tiki before 28.3 mishandles input to an eval. The fixed versions are 21.12, 24.8, 27.2, and 28.3.
Weakness: CWE-1336
Which versions are affected by CVE-2025-32461?
How do I fix CVE-2025-32461?
No fix has been published for CVE-2025-32461 yet. Limit exposure of the affected software until one is available.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-32461 being exploited?
There is no known exploitation of CVE-2025-32461 in the wild and no public exploit code.
Sources
Also known as GHSA-v676-fw8h-j3j9.