{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-32461 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-32461 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-32461 is a critical code injection vulnerability in Tiki, published on 9 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32461 and fix it if it is affected.\n\nWhat it is: CVE-2025-32461 is a critical code injection vulnerability in Tiki, published on 9 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-32461 in the wild and no public exploit code.\n\nAffected product: Tiki. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32461/ (Markdown: https://insights.sbomify.com/CVE-2025-32461/index.md)","id":"CVE-2025-32461","markdown":"https://insights.sbomify.com/CVE-2025-32461/index.md","name":"CVE-2025-32461","record":{"aliases":["GHSA-v676-fw8h-j3j9"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Tiki Wiki CMS","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code via improper input handling in the includetpl plugin of Tiki Wiki CMS.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"wikiplugin_includetpl in lib/wiki-plugins/wikiplugin_includetpl.php in Tiki before 28.3 mishandles input to an eval. The fixed versions are 21.12, 24.8, 27.2, and 28.3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Code injection in Tiki","id":"CVE-2025-32461","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2025"},"n_packages":0,"n_references":7,"next":{"headline":"Missing authorization in Sudo","id":"CVE-2025-32462"},"packages":[],"prev":{"headline":"Memory corruption in GraphicsMagick","id":"CVE-2025-32460"},"products":["Tiki"],"published":"2025-04-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["Tiki"]},"summary":"Attackers can execute arbitrary code via improper input handling in the includetpl plugin of Tiki Wiki CMS.","url":"https://insights.sbomify.com/CVE-2025-32461/"}