# CVE-2025-32461: Code injection in Tiki

> Attackers can execute arbitrary code via improper input handling in the includetpl plugin of Tiki Wiki CMS.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Apr 2025
- **Updated:** 3 Nov 2025
- **Also known as:** GHSA-v676-fw8h-j3j9

## What is CVE-2025-32461?

CVE-2025-32461 is a critical code injection vulnerability in Tiki, published on 9 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

wikiplugin_includetpl in lib/wiki-plugins/wikiplugin_includetpl.php in Tiki before 28.3 mishandles input to an eval. The fixed versions are 21.12, 24.8, 27.2, and 28.3.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2025-32461?


## How do I fix CVE-2025-32461?

No fix has been published for CVE-2025-32461 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-32461 being exploited?

There is no known exploitation of CVE-2025-32461 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32461 and fix it if it is affected.

What it is: CVE-2025-32461 is a critical code injection vulnerability in Tiki, published on 9 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32461 in the wild and no public exploit code.

Affected product: Tiki. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32461/ (Markdown: https://insights.sbomify.com/CVE-2025-32461/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32461
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32461
- OSV: https://osv.dev/vulnerability/CVE-2025-32461

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32461/
Summaries are generated and may contain mistakes; the official description above is the record.
