{"answers":{"affected":"1 open source package ship an affected version, including haproxy.","exploited":"There is no known exploitation of CVE-2025-32464 in the wild and no public exploit code.","fix":"Upgrade haproxy to a fixed version for your release line: 2.9.6 or 3.1.7.","what":"CVE-2025-32464 is a medium-severity memory corruption vulnerability in HAProxy, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-32464 and fix it if it is affected.\n\nWhat it is: CVE-2025-32464 is a medium-severity memory corruption vulnerability in HAProxy, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-32464 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- haproxy (Bitnami): affected from 2.2.0; fixed in 2.9.6, 3.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-32464/ (Markdown: https://insights.sbomify.com/CVE-2025-32464/index.md)","id":"CVE-2025-32464","markdown":"https://insights.sbomify.com/CVE-2025-32464/index.md","name":"CVE-2025-32464","record":{"aliases":["AZL-59712","BIT-haproxy-2025-32464","DEBIAN-CVE-2025-32464","DLA-4135-1","GHSA-frg5-h47x-75j9","MGASA-2025-0138","MINI-3vr5-82rp-qc5c","MINI-6vgw-7hrv-9jqp","MINI-99wq-hxp7-v73r","MINI-fp32-c5h7-h9ww","MINI-vxpg-p4jm-gwrh","OESA-2025-1495","SUSE-SU-2025:1264-1","SUSE-SU-2025:1338-1","UBUNTU-CVE-2025-32464","USN-7431-1","USN-7431-2","openSUSE-SU-2025:15200-1"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"HAProxy load balancer","requires_auth":"none","summary":"Heap-based buffer overflow in HAProxy allows attackers to execute code or cause denial of service in specific configurations.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1025","name":"Comparison Using Wrong Factors"}],"description":"HAProxy 2.2 through 3.1.6, in certain uncommon configurations, has a sample_conv_regsub heap-based buffer overflow because of mishandling of the replacement of multiple short patterns with a longer one.","ecosystems":["Bitnami","SUSE:Linux Enterprise High Availability Extension 15 SP4","SUSE:Linux Enterprise High Availability Extension 15 SP5","SUSE:Linux Enterprise High Availability Extension 15 SP6","SUSE:Linux Enterprise Micro 5.3","SUSE:Linux Enterprise Micro 5.4","SUSE:Linux Enterprise Micro 5.5","openSUSE:Leap 15.6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in HAProxy","id":"CVE-2025-32464","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":9,"n_references":1,"next":{"headline":"Extension - rsjoomla.com - Stored XSS vulnerability in RSTickets! component 1.9.12 - 3.3.0 for Joomla","id":"CVE-2025-32465"},"packages":[{"ecosystem":"Bitnami","fixed":["2.9.6","3.1.7"],"introduced":["2.2.0","3.0.0"],"last_affected":[],"package":"haproxy","purl":"pkg:bitnami/haproxy","source":"BIT-haproxy-2025-32464"},{"ecosystem":"SUSE:Linux Enterprise High Availability Extension 15 SP4","fixed":["2.4.22+git0.f8e3218e2-150400.3.22.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/suse/haproxy\u0026distro=SUSE%20Linux%20Enterprise%20High%20Availability%20Extension%2015%20SP4","source":"SUSE-SU-2025:1338-1"},{"ecosystem":"SUSE:Linux Enterprise High Availability Extension 15 SP5","fixed":["2.4.22+git0.f8e3218e2-150400.3.22.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/suse/haproxy\u0026distro=SUSE%20Linux%20Enterprise%20High%20Availability%20Extension%2015%20SP5","source":"SUSE-SU-2025:1338-1"},{"ecosystem":"SUSE:Linux Enterprise High Availability Extension 15 SP6","fixed":["2.8.11+git0.01c1056a4-150600.3.6.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/suse/haproxy\u0026distro=SUSE%20Linux%20Enterprise%20High%20Availability%20Extension%2015%20SP6","source":"SUSE-SU-2025:1264-1"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.3","fixed":["2.4.22+git0.f8e3218e2-150400.3.22.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/suse/haproxy\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.3","source":"SUSE-SU-2025:1338-1"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.4","fixed":["2.4.22+git0.f8e3218e2-150400.3.22.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/suse/haproxy\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.4","source":"SUSE-SU-2025:1338-1"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.5","fixed":["2.4.22+git0.f8e3218e2-150400.3.22.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/suse/haproxy\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.5","source":"SUSE-SU-2025:1338-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["2.8.11+git0.01c1056a4-150600.3.6.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/opensuse/haproxy\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2025:1264-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["3.2.0+git0.e134140d2-2.1"],"introduced":["0"],"last_affected":[],"package":"haproxy","purl":"pkg:rpm/opensuse/haproxy\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15200-1"}],"prev":{"headline":"Sudo Inclusion of Functionality from Untrusted Control Sphere","id":"CVE-2025-32463"},"products":["HAProxy"],"published":"2025-04-09","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["HAProxy"]},"summary":"Heap-based buffer overflow in HAProxy allows attackers to execute code or cause denial of service in specific configurations.","url":"https://insights.sbomify.com/CVE-2025-32464/"}