# CVE-2025-32464: Memory corruption in HAProxy

> Heap-based buffer overflow in HAProxy allows attackers to execute code or cause denial of service in specific configurations.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2025
- **Updated:** 23 Apr 2025
- **Also known as:** AZL-59712, BIT-haproxy-2025-32464, DEBIAN-CVE-2025-32464, DLA-4135-1, GHSA-frg5-h47x-75j9, MGASA-2025-0138, MINI-3vr5-82rp-qc5c, MINI-6vgw-7hrv-9jqp, MINI-99wq-hxp7-v73r, MINI-fp32-c5h7-h9ww, MINI-vxpg-p4jm-gwrh, OESA-2025-1495, SUSE-SU-2025:1264-1, SUSE-SU-2025:1338-1, UBUNTU-CVE-2025-32464, USN-7431-1, USN-7431-2, openSUSE-SU-2025:15200-1

## What is CVE-2025-32464?

CVE-2025-32464 is a medium-severity memory corruption vulnerability in HAProxy, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HAProxy 2.2 through 3.1.6, in certain uncommon configurations, has a sample_conv_regsub heap-based buffer overflow because of mishandling of the replacement of multiple short patterns with a longer one.

Weakness: CWE-1025 (Comparison Using Wrong Factors)

## Which versions are affected by CVE-2025-32464?

1 open source package ship an affected version, including haproxy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haproxy` | Bitnami | From 2.2.0 | 2.9.6, 3.1.7 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 2.4.22+git0.f8e3218e2-150400.3.22.1 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP5 | All versions | 2.4.22+git0.f8e3218e2-150400.3.22.1 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP6 | All versions | 2.8.11+git0.01c1056a4-150600.3.6.1 |
| `haproxy` | SUSE:Linux Enterprise Micro 5.3 | All versions | 2.4.22+git0.f8e3218e2-150400.3.22.1 |
| `haproxy` | SUSE:Linux Enterprise Micro 5.4 | All versions | 2.4.22+git0.f8e3218e2-150400.3.22.1 |
| `haproxy` | SUSE:Linux Enterprise Micro 5.5 | All versions | 2.4.22+git0.f8e3218e2-150400.3.22.1 |
| `haproxy` | openSUSE:Leap 15.6 | All versions | 2.8.11+git0.01c1056a4-150600.3.6.1 |
| `haproxy` | openSUSE:Tumbleweed | All versions | 3.2.0+git0.e134140d2-2.1 |

## How do I fix CVE-2025-32464?

Upgrade haproxy to a fixed version for your release line: 2.9.6 or 3.1.7.

## Is CVE-2025-32464 being exploited?

There is no known exploitation of CVE-2025-32464 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32464 and fix it if it is affected.

What it is: CVE-2025-32464 is a medium-severity memory corruption vulnerability in HAProxy, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32464 in the wild and no public exploit code.

Affected packages and fixed versions:
- haproxy (Bitnami): affected from 2.2.0; fixed in 2.9.6, 3.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32464/ (Markdown: https://insights.sbomify.com/CVE-2025-32464/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32464
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32464
- OSV: https://osv.dev/vulnerability/CVE-2025-32464

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32464/
Summaries are generated and may contain mistakes; the official description above is the record.
